Major Excel and Outlook problem

Installer(.exe or .msi): .exe

License type(Free, Trial/License code): Enterprise licence

Studio/Robot version: Both

Current behavior: Unstable

Screenshot: Not possible(sensitive data)

Hi all,

I wonder if you can give some insight into our situation? We have around 5 processes running on production during the day and in the last month, all of them started experiencing the same excel or outlook error.
What happens is that process will run and it will just go in pause like state with EXCEL.EXE running in the background. We noticed that the robot sometimes can’t open or close the file (we are not sure which is it). When robot hits the excel app.scope it will just go to pause like state. This happens in unregular intervals. Sometimes the process will be completed and sometimes it will not. But the problem is that UiPath does not recognize it as an error. It won’t brake it wont go to exception it will just be on pause like state until we manually kill EXCEL.EXE. The same thing will happen with outlook. Robot will try to read the emails but then it just goes in to pause like state with OUTLOOK.EXE opened in the back.

We are using excel app scope with close workbook activity. Could it be an issue with interop ? or MS Office package updates ?

We are running the latest enterprise edition of UiPath in a production environment with only robot.exe doing the executions.

I will try and upload the pictures later but there is not much to see. Just the robot icon ‘hovering’ not doing anything while EXCEL.EXE stands in the background. When will kill it (excel.exe) the whole process will fail and crash.

Anybody had some similar issues?

1 Like

Hi @Petar_Soce,
To to include close application or kill process activity before excel scope activity to be sure that every related process will be gone before robot will start the excel.

Tried it. Not working. Error will pop up every time. the remote procedure call failed. We are trying something else now. Will let you know will it work…

EDIT: Not working. After each excel.scope we have close workbook and then we invoked the code. GC.Collect()

But it seems that it is not working also. EXCEL.EXE is still opened in the background. Sometimes…Inside 5hours it will happen atleast two times.

1 Like


We updated to new enterprise version and now neither one of “type into” activity with simulate click is not working and “wait for the page to load” is also not working.

It worked on the previous versions.

Can you tell me which Excel version do you have?


One more thing. I would like to ask you if you could describe a little in which step/activity problem occurs? Are doing Excel automation or the problem is related to Ui automation inside the excel? This will help us to investigate the problem.

We are now also sometimes getting errors " Error opening workbook. Make sure excel is installed"

Can you please provide me information on this?

Problem occurs when trying to open or write inside excel scope. We cant know for sure since the robot will not issue an error. It will just be in pause like mode with EXCEL.EXE in the background. When that process is killed (excel.exe) the whole process will crash. This is not happening on one specific process. It is happening on over 5 diferrent processes running on two different production environment. Both are using Windows 7 OS and Excel 2013

Here is a screenshot of the robot. In this shot robot shoul be working but it is just in pause like state.
After the excel.exe is killed the process will crash.

We have just gotten confirmation from our IT department that the problem is causing one of the antivirus software which was newly installed.

Thank you all.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.