Process stuck in running state "forever"

Hi all, I have problem with one of my processes that occasionally gets stuck in a running-state. I then have to kill the process and start it again, and then everything works ok.

The process is quite simple:

  1. Read one or more excel-sheets from a folder.
  2. Do some validation-logic on the data in each sheet.
  3. If validation ok, move the Excel to another folder and write the path to queue. Easy peasy.

I always use the “Close workbook” activity after I’m finished processing.

This doesn’t happen often, but when it does happen no error messages are written to the log. The process is just stuck. I also can’t see any particular pattern as to when this happens.

When I log into to the robot I can see that the process is running but that nothing is happening.

Hanged%20process

I can see here on one other user had a similar problem, but he used Outlook instead.

The UiPath-version we are using is 2019.4.4 Enterprise Edition.

Any help is appreciated. Thanks.

1 Like

Check your desktop’s memory. Try to clear down processes / cache as when using excel it and UIRobot it can use memory and cause process to ‘Freeze’ - sometimes if memory allocation resolves itself process may continue, otherwise you have to kill / stop as you have done already.

Before starting the process kill EXCEL process.
Even after closing the workbook, kill the EXCEL process and see if that works for you.

Regards,
Karthik Byggari

Thanks for the quick reply @TimK and @KarthikByggari. Next time this happens I can check the CPU and memory in the Task Manger (I forgot it this time).

Question about kill Excel-process. I was under the impression that this will also kill the process for other robot-users on the same server. Is that correct? I don’t want to use kill if that will disrupt the other robots that are running on the same server.

Thanks again.

it should only kill that process on that particular desktop - it depends on your setup of how you are running robots.

I.e. Each robot has its own desktop or you are running all automation back end via server side processing.

Thanks @TimK. I tested Kill Process now by having two robot-users logged on simultaneously on the same server where both had an Excel-sheet open. I then ran a “Kill Excel” process for the one robot, and only the Excel for that user got killed. But I did get an AggregateException, which is probably caused by the Kill Process activity not having the necessary permissions to kill the other users Excel-process. I solved this by setting ContinueOnError=True.

If this solves my problem or not is hard to say, I have to let the process run for a while. If it doesn’t freezes anymore this thread can be marked as solved. I will report back here next week with the result.

1 Like

Hope it works :ok_hand:

As i mentioned it can get quite memory hungry so it is a good idea to clear it down when possible by killing any unused applications etc.

1 Like

Hi all. I can report that I haven’t had any problems since my last post, so it seems that killing the Excel-process did the trick.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.