Mainframe Error-009 with Uipath

I have used terminal activities to automate mainframe terminal . It is working fine on initial 2-4 screens but after a point it is throwing error -009 on application and not getting navigate further. Anyone has idea about this issue

Hey @samikshaB ,

It is a common from Main frame. check the connections and also the settings.


What details needs to be checked and filled can you please give any idea


  1. Check the Selector: The first thing to do is to check the Selector used to interact with the mainframe application. Make sure that the Selector is valid and points to the correct field or screen. You can use the UiExplorer tool to inspect the Selector and make sure that it is correct.
  2. Verify that the Application is Running: Check that the mainframe application is running and is accessible. Ensure that all the required components are installed and configured correctly.
  3. Check that UiPath Terminal is installed: Ensure that UiPath Terminal is installed on the machine where UiPath is running. If it is not installed, you can install it from the UiPath Studio installer.
  4. Check that the Session is Connected: Verify that the UiPath Terminal session is connected to the mainframe application. You can do this by opening the UiPath Terminal and checking the status of the session.
  5. Check the Mainframe Application Settings: Check the mainframe application settings to ensure that the fields or screens being accessed are accessible and can be interacted with by UiPath.
  6. Try Increasing the Timeout: If the error persists, you can try increasing the Timeout value in the UiPath Terminal activities. This will give UiPath more time to interact with the mainframe application and may resolve the issue.


Everything is working fine and UiPath is able to work properly with terminal screen but only throwing error on the screen i have mentioned.


Did you check manually. Whether the message is coming in manual mode?


can you check with IT team

as this related to mainframe they can guide you with proper details

in the link it is giving some macro related error


Nop it’s not coming while mannually performing same actions.

Yes I have tried to connect with my mainframe team they also don’t know anything.

are there any macros

and check manually are you able to proceed and

check if you are any value which is not permissible than the length

ex : user name is some thing like 8 characters or date having a limit or format


Manually i am able to do, no macros , values i am providing are proper info.

I am converting the date also in the format accepted by terminal which is ddmmyy

can you try to give some delay and check


I tried that too still not working