Logging onto Orchestrator in Unattended Mode

I am having trouble logging into Orchestrator from the UiPath Assistant when installed in unattended robot. I need either the Machine Key or the Client ID and Client Secret.
Thank you!

Create a new Machine template. After you create the Machine Template, you will receive a popup with your Machine credentials.

When I do this I get the error:


Some steps I think you are missing.

Create a machine template.
Add the machine template to the Modern Folder.
Add your Robot user to the Modern Folder.
Edit the Robot credentials

In the Assistant use the Client ID or Machine Key connection. ( URL will be https://cloud.uipath.com/ORG_NAME/TENANT_NAME/orchestrator_/ )

As far as I can tell I have done all of this.

Click on learn more link to find out the cause.

All it does is bring me to this document.

I don’t see anything related to my problem on it.

Check if you have this setup in place in the Tenant

Okay, so my Attended robot authentication is different from what is shown there. Is this important since I am working with unattended? My page looks as follows:

When I click on the link to disable it I am taken to the page shown below.

Here I do not see a place to disable it. Thank you for the help I really appreciate it!

Check if you disabled the User License Management

I do not have that window which the arrow is pointing at.

Okay, so I just tried again and it has now worked. I guess something that you told me fixed it but took a minute to update.

Are you sure that you are not using Classic folders?

Thank you so much for your help! I really appreciate it and have been trying to fix this all day.

You know Assistant isn’t needed for unattended automations, and isn’t part of how unattended automations run, yes?

I am not. How do the unattended automations run? From what I have seen I assumed the assistant was what connected to orchestrator to allow for unattended processes to run.

Assistant is just a user interface for humans to run attended automations. It’s Robot.exe that actually does everything - running the actual job, connecting to Orchestrator, accepting commands from Orchestrator, etc.

Also, it sounds like you’re remoting (ie RDP) into your server(s) that the automations run on. If you do that, make sure you SIGN OUT completely from the start menu. Don’t just close the RDP window, don’t lock it. Sign out completely before trying to run a job. Orchestrator creates its own RDP connection, if you’re already signed in with the same account and then just close the RDP window, you foul up what Orchestrator is trying to do.

1 Like

I have done that. I am still running into the same problem of it disconnecting.