Unable to run unattended robots

I have allocated runtime licenses to my community tenant (I only have one tenant) and I cannot get the process to trigger.

I am using windows 11, I have connected my assistant via machine key. This windows logon is going to be used only fur unattended processes.

In assistant it successfully connected but said it was not able to get a license

Here is a video walkthrough of my issues, sorry for the 6 minutes but I figured this would be the best way to help show what I have tried

Try to Sign-in in UiPath Assistant. Maybe you set in your Orchestrator the interactive Sign in.

Also, try to create a Machine template instead of a Standard and use its key to connect to your Orchestrator.

Also, it seems that you don’t have the right service installed for the Unattended robot. You should see in services.msc UiPath Robot runs as System Local Account.

So uninstall all the UiPath Studio or UiPath Platform from your machine. Restart the machine. Download the Studio 2022.4.4 and install in Unattended mode. Restart the machine. Open Assistant and connect to your Orchestrator using the Machine template (with 1 Unattended runtime) key. Also, it may be that you still need to sign in to UiPath Assistant.

Let us know if this helped.

  1. Signing directly into orchestrator from the assistant does not work

  2. When it installed the installation was for “all users” on this PC, during windows setup. But this should not be a problem as Orchestrator is suppose to have the ability to let users run unattended robot, it’s even in the users settings, so in this case no machine key would be needed?

  3. This is a fresh version of windows and a fresh version of Studio, what would prevent the services from installing correctly the first time?

What makes the machine template different than that of a standard machine? I would think they are mutually inclusive but the template would be to standardize quick setup with settings?

After uninstalling and reinstalling the installation did not give me an option for unattended…

But I tried connecting to the new machine template that I created and still no UiPath services launch

Check this article as I think you are using a Community License and you installed by a Quick action without checking the Advanced Settings. Deploying Unattended Robots - Community License

I did choose the advanced settings