Level 3 Assignment 2 - Performer Process

Hello everyone, Can someone please look into this attached performer process! I’m experiencing strange errors while executing!

  1. The performer process closes automatically after a few successful “completed” queue items.
  2. The robot is not selecting the file while uploading I need to click the file manually to upload it.
  3. When Downloading Yearly Report, the Save and Save As were too slow, so I’ve changed properties from “Wait for Ready to None” after reading various posts.

Thanks in advance.
Vis

Generate_Yearly_Report_Performer_Process.zip (526.8 KB)

Before running the performer, double-check what the dispatcher loaded into Orchestrator. It may be that the dispatcher isn’t capturing everything it needs to.

Hi @Anthony_Humphries thanks for quick response, I looked into the Dispatcher process and Orchestrator. All the queue items are captured to the orchestrator (I counted the number of items from ACME to verify), but couldn’t find any issues! Please correct me me if I’m missing something here.
Thanks

Can you upload your Dispatcher process as well? It will help me to troubleshoot this.

Generate_Yearly_Report_Dispatcher_Process.zip (506.9 KB)
Generate_Yearly_Report_Performer_Process.zip (526.8 KB)

Hi @Anthony_Humphries please see the attached. One more question on test data, does test data in ACME System changes every time (I mean adding new entries!, the reason whenever I run Dispatcher process, the number of items are changing? initially I’ve got 9 then 14 and now 19 items!). thanks

You have to go to User Options -> Reset Test Data to get a fresh set of data. And yes, the number of items is subject to chance once you do that. If you want to keep the items consistent, you have to mark the ones your process marked as Completed back to In Progress so your performer will pick them up again.

Thanks @Anthony_Humphries

I’ve tested the process. Where you’re calling the “Create_Yearly_Report” workflow, you have out_YearlyReportPath set as an In argument. This is sending null data at the end of the process and not uploading the file.

Also, I recommend lowering the default timeout to make testing the process faster (I found that 5 seconds was enough in general, but tweak it as you see fit).

Hi @Anthony_Humphries thanks for testing the process and find out what is not correct. “Create_Yearly_Report” invoked in Process.xaml and changed argument to “out”.

Timeout changed to 5sec and running the performer again. Will keep post you the outcome.

Once again thank you for your time and help.
Cheers

sorry to annoying you, I’ve tried it took 11mts to process 1 queue item! then ACME closed itself. please see the attached updated performer process. Generate_Yearly_Report_Performer_Process.zip (771.8 KB)

Would you mind to go through again and guide me if i’m missing anything?
thanks

Adjust the default timeout. Every time you use Element Exists and the element does not exist, the activity waits for the full timeout period. If the monthly report is found, I noticed you have two element exists for the text boxes which appear only when the process fails. Since the default timeout is 30 seconds, you have to wait a full minute for each successful month.

This process ran well when I set the timeout to 5 seconds for me, though this should be adjusted to what works for you.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.