Lesson 7, ClickOCRText Dropdown problem

Greetings!
I’m working on Lesson 7, Practice 2, Level 1 Foundation training.
I’m using UIPath CE 2019.4.2.

Using the ExpensIt.exe application, record a set of actions that generates an expense report. My problem is with dropdown menu and it is driving me crazy. I have three recordings.

The first recording, I’m just manipulating the dropdown menu. Everything works. Click Image creates the anchor, Click OCR Text clicks the “Marketing” label from the dropdown menu.

The second recording, full recording of Practice 2, Lesson 7. Basically it should fill in all of the fields/buttons to create expense report. The dropdown action is now part of a bigger sequence. The dropdown is exanded but the Click OCR Text cannot find “Marketing”.

The third recording starts with clicking the dropdown menu first and searching for “Marketing”. It works. It than proceeds to fill in some of the other fields. The point is, starting the sequence doing the dropdown works. But when the dropdown action is part of a bigger sequence, like in the second recording, It stops.

Any light on this problem would be much appreciated.

Main.xaml (33.0 KB)

Hi @bmildh

Welcome to our UiPath Forum! :slight_smile:

When you say that it stops, what error message are you getting? Could you provide a screenshot?

The robot gets to the dropdown control, clicks it, and then it times out. The activity that times out is Click OCR Text. To me, it feels like It can’t find the string “Marketing”, but perhaps it has something else?


I got a same problem and still not solved. Have you found the solution?

Not really.

I am thinking that the videos might not be correct given all the updates since they were made.

You are right and I solved it by using Select Item activity. It can be applied. If you don’t know, pls send mail to me, it will be easier to explain. jeongyob.song@dhl.com

Yeah, I got It to work. The Select Item Activity must be outside the CV Screen Scope in order to work.

Thanks for the tip!