Lesson 7 Practice 2: Expenseit standalone - stuck


#1

Hi,

I am stuck at lesson 7 practise 2. It says "…For Cost Center, use image recognition just like you did for employee number to expand and click in the dropdown menu.

  • Next, select Click Text and use the entire window as the selection element (simulating a citrix environment).
  • In the Text to be found field, type: Marketing ".

As Default value cost center is set to “Sales” in the dropdown menue, so “Marketing” can never be found by OCR engine. When running the solution it also stucks.

What am I doing / understanding wrong ?

Br,

Dennis


#2

Hi ,
Just make sure drop down is expanded before doing click text .


#3

Same problem here! The drop down is expanded at first when starting “click text”. But then I have to choose an ocr engine (Google OCR). That moment the drop down collapses and it is impossible to expand it again (and keep it expanded) to be scraped.


#4

@sonja and @dsuhari, my apologies if this doesn’t help you. Your questions certainly helped me, so I though I would share.

I missed that when I was going through the exercise. I was so excited that I got it to run to the end that I didn’t notice “Marketing” wasn’t selected when the robot finished.

First, if you’re doing this on the desktop, it may not work (I haven’t been able to get it to, anyway). If you have a Virtual XP or VirtualBox XP (or other OS) to use, or can VNC into a virtual machine, this should work for you.

To get the dropdown to stay put, you need to do some things with the image recognition.

Click Image from recording menu.
Then you have to hit indicate once you have drawn a red box around “Cost Center.”
Click Indicate

Once you click “indicate” you’ll be able to draw another red box around the region where it says “Sales”. Now your dropdown will stay put, and you can do a “Click Text” activity. Here’s what it will look like before you do your “Click Text”, and it will stay that way during the OCR.

28


Citrix recording - no OffsetX generated?
#5

Unfortunately, I have the same problem here. Have tried everything suggested in this thread, but cannot get the dropdown to stay open in order for OCR to read it.


#6

Unfortunately, I have the same problem with the dropdown list.

Worse, when I try to record activities on a virtual machine, not the desktop app, recording doesn’t work at all, neither capturing text nor typing text, or clicking a check box etc.

For example, when I put a frame around a caption, with the click image activity, the Set mouse position window wouldn’t appear (as it does with the desktop app).

I’m using a LinuxLite VM under VMWare 12 Player. In the VM settings, I can share host folders but there seem to be no options for clipboard sharing between host and VM.

Any ideas?


#7

I had the same problem with a disappearing dropdown list (in a different question earlier in the series) someone told me to use the F2 key which introduces a wait state.

What you do is hit ‘indicate’ (the drop down will have disappeared) then you press F2, this give you a few seconds to go back to the drop down and open it up. After this 3 second wait the program reverts to selection mode again (with your drop down now open you can now select the entire app window for text scraping and because the drop down is open you should be able to scrape the dropdown data).

I don’t understand why this F2 functionality is not in the walk through as this is the only way I have found so far of dealing with this disappearing drop down issue.

I hope this is of help.


#8

I am doing Lesson 7, I need to know which virtual machines you all used for Citrix Practice?