I’m trying to use drop down and select an item. I used Click Activity and it didn’t work. Then I used Select Item and I’m getting the following message. I ready many posts and someone suggested adding HotKey. I tried using HotKey and it still didn’t work. Below is the screen shot of the error and Selector:

Any suggestion will be greatly appreciated.



i think hotkey needs to be the final thing in the selector…

@bcorrea, can you please tell me how to add HotKey in the selector.


Thanks @bcorrea.The previous error got resolved but now I’m getting this.

Currently I’m using Select Item.

I’m trying to select the Month - from Oct-FY20 to Dec-FY20, which is 3rd down the list.



is the select item activity the first one you have after reaching the page? if the complete not helping, sometimes we see “OCT-FY20” and but it can have some extra space in the end or something…

Yes the Select Item Activity is the first activity I’m using when the page loads. Because this page can take some time to load, I added delay of 100000 on the previous activity.

I cannot control the extra space if there is any. Is there a workaround.

Also I changed to Interactive and still getting the same issue.

I also used the Click Activity, did F2 to bring the menu down and after the counter is 0, selected the month and I get the following error.


i wouldnt put in that delay after, instead i would use after the click, something to make sure that Fiscal Month menu is there and ready, like Element Exists and set there the timeout as 100000.

I removed the Delay from the Activity before this. I’m using the Select Item Activity and below are the properties. How do I add Element Exists?


Before the Select Item activity, you put an Element Exists activity and use the same selector that is already working for the select item activity. In this you will set the Timeout to 100000. Now the Select Item activity wont need WaitForReady or Timeout changes.

Hi @bcorrea, it’s still not working. I added the Element Exists Activity
Somehow the Select Item or Click is not able to understand the dropbox. It’s Cognos application from IBM. Not sure if UiPath doesn’t work for DropBox’s in certain applications.

When I use Click Activity, I use F2 to pull the dropbox down and when the counter is at 0 and when I select the month, it says Timeout.



ok, then it must be the item text that is not exact, try like this: "DEC-FY20*" or "*DEC-FY20"

I tried both options and the same issue is there. The mouse doesn’t even move to the Fiscal Month dropbox.


can you see the dropdown in the page with its items before you get the error?

The mouse remains where ever he was when I run the program. It doesn’t come to the month or dropdown.


Any other suggestion how the dropbox can work? Thank you for your help.

Sounds like there is no solution to this issue. There are couple of other posts similar to mine and they were never solved. How can this be flagged, so Uipath can make an update to their code?

Sorry i could not help until the end, but there is not a lot we can do without access to your system :frowning:

@bcorrea, I can understand that without accessing the system, it’s hard to find a solution but what are my options?