Lesson 6 - RPA Challenge - App not selectable in Anchor Base

Hello,

I am having some issues with the Anchor Base activity for Lesson 6 - RPA Challenge. I completed the challenge using the relative selectors but I want to do it using Anchor Bases, however I am unable to. I looked at some other video tutorials (https://www.youtube.com/watch?v=M0jpfyrYhbQ) however when I try to copy the video, it doesnt work. From what I have seen, the difference is the app=‘iexplorer.exe’

However when I try to click it (even with Ui Explorer) it doesnt let me add it to the selector?
so I end up with this:

When I try manually typing in the app info to get:

UiPath doesnt allow this to be validated? So I am stuck with the version without app which doesnt seem to work.

What am I doing wrong?

@Sekondax
AnchorBaseRPAChallenge.zip (10.0 KB)

Worked at my environment (Windows 10, Internet Explore, UIPath Studio 2019.2)
Attached a simple workflow

  • Type Into activity with UIExplorer Indicate Anchor
  • Anchor Base Activity with Find Element Activity + Type Into Activity.

Please try attached project.

@hermawan

Thank you for the help, in my original workflow I was using “attach window” rather than “open browser” as you did, once I changed this everything worked well.

Is this something that I need to be aware of in the future with other applications e.g. ERP systems - that “anchor base” doesnt work well with “attach window”, or is this just an isolated example?

@Sekondax

It should work with Attach Window activity too.

This workflow use Attach Window - Anchor Base - Find Element - Type Into:
AttachWindowIExplore.zip (2.0 KB)

This Selector discussion might help: