Lesson 10 Get Text PDF is not working - Just outputting Ávpageview"

uiautomation
pdf

#1

I tried running ‘Get Text PDF’’ in lesson 10 and I get ÄVpageview" as ouput instead of “'40”

I tried independently also. It is not working. I may be missing something here.


Pdf extraction with get text
#2

I also encountered the same situation, can not choose “¥ 40.00USD”, the situation appears under the map (2017.1.6522, framework 4.6)


i see this


Problem in Lesson 10 - PDF
#3

Thanks, it works!


#4

Hi

I too am attempting the practice examples of Lesson 10 of the Foundation Training course and have the same issue. In UiExplorer, selecting any part of the PDF only returns the same selector, with just the top level (acrord32.exe and file name) and then a series of cls statements, ending in '.

I do not get the additional selectors as per the downloaded PDF Samples UiPath project file, that show also and . When I run the downloaded project, it errors with ‘Cannot find the UI element corresponding to the selector’.

When I run my version, the output from the Get Text variable contains just the text ’ '. My version does have a Clipping Region set, whereas the downloaded version does not.

Is this perhaps caused by a new version of Adobe Acrobat (I just installed the latest version on my new Windows instance).

Thanks
Steve


#5

I’ve resolved the problem from another similar thread. The solution was to de-select and then re-select the Adobe Acrobat Reader preferences:
Edit > Preferences > Accessibility:

  • Use document structure for tab order when no explicit tab order is specified
  • Enable assistive technology support

It may be just the latter that is needed.

I also have the same limitation, in that once you close Acobat Reader, it can no longer find the element. I have to re-open Acrobat Reader, de- and then re-select the options once again and leave Acrobat Reader open for it to work.


#7

any one help me , because i also stuck with ‘AVpage view’ message while using get text in uipath for pdf


#8

I have applied mentioned workaround and changed the settings of Adobe Acrobat Reader preferences but still stuck with ‘AVpage view’ message while using GetText for PDF.
Please guide me on this.


#9

It is really helpful.


#10

Thanks this solution (workaround) works fine form me :slight_smile: