Key Press Trigger missing numEnter?

Hi

I’m in the process of creating an attended robot that is triggered either by clicking a button or the numeric Enter key.

However in the Hotkey Trigger activity I cannot seem to find an option for selecting the numeric Enter key. In the Send Hotkey activity it is listed as numEnter - so I have tried that in the Hotkey Trigger activity as well. But that does not seem to do anything.

Is the numeric Enter left out by choice or? I can see that num0, num1, num2, etc exists so why not the numEnter?

@jacchr I guess the regular enter key should work.

@monsieurrahul it does work indeed. However the application I’m automating against distinguished between normal Enter and NumEnter - to add an order line NumEnter is required. It also works with the Send Hotkey activity where both enter types can be used - but the robot should only be triggered when NumEnter is pressed.

Seems that numEnter is implemented in 2020.4 - just downloaded the beta version. However it does not seem to be working as nothing happens when using the numEnter as a trigger. Tried with both NumLock enabled and disabled.

Hi @jacchr,
Please check if any of additional attribute like these will work for you:
image

Hi @Pablito

I am not sure that I have this option available for trigger based events.

Im sorry. Seems that I wrongly understand. You wrote that:

Then:

So what I proposed is that maybe your send hotkey activity is still not working properly in your application because it reads numEnter different way. So you could try to set this options I showed on screenshot to test if those option will work in your application you’re trying to automate.

Hi @Pablito

It is not the Send Hotkey activity I am using :wink: But the Key Press Trigger activity - I do not see that I have the options from your screenshot.

Hmmm it seems that selector might be problem here. Can you experiment with the same key using other selectors and other applications?

I tried doing the automation in Notepad as well with the same result. I then changed the trigger key to normal Enter and then it works. But when changing the key back to numEnter nothing happens - regardless of NumLock being turned on or off.

Hi @jacchr,
I tested it and seems that you’re right. It’s probably a bug. I submitted this case to our tracker, hopefully it will be fixed soon. Thank you.

1 Like