JDE Error

Hello Forum.

I try to automate some tasks in ASPECT4. I tried downloading the runtime plugin for automating java-based applications from tools, and from the popup in studio when you try to access the application (see picture).

When the installation is successfull it recommends me to install the plugin again, and I cannot access any selectors from the UI.

Does anyone have tried this, and did you find a solution?

Hey @Frederik_Boelskifte - It could be that your application is using a custom JRE/JDK install directory. I would suggest reading the following:


Also β†’ About the ScreenScrapeJavaSupport Tool

Can help a lot in case of a custom install directory!


In addition to what @FrankSchikora suggested, you could also try to upgrade to one of the latest UiAutomation package version.

Good luck!

I tried it all but did not work.

It cannot find Java, cause it properly an imbedded Java JDK 14 installation.

Do you have any answer to this problem?

Hi @Frederik_Boelskifte - if the jdk is embedded in the application you should be able to install the extension with the following command:
ScreenScrapeJavaSupport.exe /install /jrepath β€œβ€

If that also doesn’t work I think you would need to contact support to see if they would be able to help! β†’ Contact Technical Support

1 Like