Item in drop down not select

item in drop down not select when execute application but when I try to debug mode then it work fine.In debug mode it select the item.As mention in screen shot.

try a ‘click’ action instead and click on ‘select’ maybe that helps.

use Click activity before select item activty!

Go into the properties of ‘Select item’ activity and open the ‘target’ option by clicking on the plus. Now select ‘WaitForReady’ and choose ‘COMPLETE’. IF this doesn’t solve it either (but it should), build a ‘click’ activity into your workflow (‘click’ before ‘select item’ activity)

If this helps please mark my comment as ‘Solution’

@Aditya10989

As you said in debug mode it’s working fine, so could you increase the delay before time and try it again.

Hope it will work.

Now right now I checked in debug mode also it select item for 2 sec and after this it automatically select the select item.As mention in attachment.
And I check in manually it work fine.value of item select by select item not inserted text manually.



@Palaniyappan @Pradeep_Shiv

1 Like

did you tried above method which i told you?
like use click activity before select item!

yes try but not work form me

didi you try making name = ‘*’ in selector like this

like this…?

yes! @Aditya10989

yes but not work I don’t know what is the issue.In debug mode it show the item when I click on browser then it again move to select item

do one thing!
remove name = ‘*’ just let it be like
< webctrl tag=‘Select’/

Now I do one thing.In my drop down two items as mentioned in attachment.Now I selected Partial Contribution value then it work fine if I select Final Contribution then it move to select item


@Palaniyappan

yes try but not work

Fine
We have only two options right
Did we try with normal SEND HOT KEY activity with key as down and then a enter like how we do with keyboard without mouse

That is use a Click Activity on that drop down
—then use a SEND HOT Key Activity With key as down and no element selected for selector
—then use one more down key for second option
—and after reaching the appropriate option use a Final Send hot key activity with key as enter

With this way it will work either

Cheers @Aditya10989

2 Likes

Thanks man I think this worked for me.But I am shocked same drop down for one item it work fine with select item and for second item I need to use hot key.

firstly its work but right now its not working…??
I am not able to select the item again.code mention in attachment

Fine

keep all the hot key activities inside a GET ACTIVE WINDOW activity
and dont select any element for SEND HOT KEY when place inside the GET ACTIVE WINDOW activity
@Aditya10989

like this …?
try but not work