Any idea why this error populates when we choose select item to handle drop down items- refer screenshot


Can you try using a click activity before the select Item ?

still facing the same error after using click

In case of an Select Box is not working as expected follow this procedure:

  • do a click activity before select item activity
  • give to both activity a delay before of 1000 ms
    if its not working
  • increase delay to 5000
    if its not working do debug and set a breakpoint on select item
  • debug
  • wait a longer time before select item
    If its working then:
    Your application / Selectbox is not properly loaded and you should sync your implementation on loading

However crosscheck that your selectors are right. Especially select boxes are sometimes wrong recognized by “indicate …” within UiExplorer.

Please let us know the result of your checks

I tried both 1000 and 5000 delays, but still facing the same issue

Ok So please give more details:
What for type of application you are dealing with: Web, Java Based
Give screenshot of UiExplorer along with displayed Properties and Hyrachie
give a screenshot of the properties for select item activty

Application path – “C:\ProgramData\Microsoft\Windows\Start Menu\Service Delivery Tools\EMicroSTART 2011.lnk”

This is not web application.

Ok Great. well done with the screen shots. your selector is not refering to the combo box only to the window.
this can have to reasons:

  • your application is blocked for automation (e.g. selector retreival mechanism, rights…)
  • your selector needs to be redefined

for last please indicate item in UiExplorer to the combobox and make sure that sometining with combo is in the new selector entry. If this is not working inspect in the visual tree if you can find the combo box.

this my selector for combo box, and the earlier selector is of Attach window.

How to find the Application is blocked for automation or not ?

find out blocking is not easy but on the first look its not looking bad.

  • does the new selector throws an error again?

If yes please expand the children of the combo box in the visual tree down to leaf and provide a screenshot

if i use set text activity , instead of select item activity…bot is entering the options in dropdown but it throws this error during bot execution.

where is this part, can u highlight please. ------“expand the children of the combo box in the visual tree down to leaf”

scroll down to combo box
Edit: e.g. ThunderRT…ComboBox is the Box of interest then click on triangle and expand all children

can you please confirm you want to select: Combobox next to combined risk assessment?

Ok so just a little input for your next analysis:

  • you have some more comboboxes in your aplication, so make your selector stronger (e.g. uifield name, index)

try again.

Other stratgy to deal with a combobox:

  • get Children activity: selector to Box filter to the entries e.g the labels or list items
  • filter to the entry of interest (e.g. classical for each or LINQ by using the text attribute uielementvaraible.Get(“text”).equals(…
  • click activity with refering to the found/filtered item

Let us know your feedback on the recommended actions

1 Like

Issue is resolved. Thank you all:)

1 Like