Issue with Robot downloading packages

Hi all

I’m having an issue with a new package we’re using from the Go Marketplace - The Office365 application pack.

I’ve uploaded a simple process to check Outlook and return the subject of the last 5 emails. When the process is run, it fails before it starts with the following error message:

Info: The feed ‘Official []’ lists package ‘UiPath.MicrosoftOffice365.Activities.1.1.3’ but multiple attempts to download the nupkg have failed. The feed is either invalid or required packages were removed while the current operation was in progress. Verify the package exists on the feed and try again.

Any ideas? We’ve run multiple processes on this robot previously without issue

1 Like

@AndyD - Is Robot having an administrator related permissions to download the packages?

I’m not sure. I don’t have access to the robot login at the moment so can’t see what’s going on. But looking at the logs, the failure is before it even says the process is starting so I’m not sure it’s even initialising

I faced similar issue with one of the package - later we identified → robot user is not having an access to create .nuget/packages folder.

1 Like

Ok thanks, I’ll look into that,l hopefully it’s a quick fix

I’m just confused as this robot has run many processes previously and would have downloaded packages including ones from the Go Marketplace

1 Like

Did you get your process running? I’m facing a similar issue. Just getting ready to inspect permissions, but unsure why it changed after many successful runs.

Today I had the same problem and the solution that resulted was the following:

  • Environment: Production
  • Error:
  • Solution: In the production environment the project folder was copied and opened with UiPath Studio. The production environment had UiPath Studio installed. When the project was opened, UiPath Studio automatically downloaded the package and component updates.

I hope it helps you if it does.

i’m facing the same issue here. Can you describe more specific solution?

Try to upload activity package to Orchestrator. Robot can also download it from there.

Another option that worked for me was to go to the path C: \ Users \ USER_HERE \ .nuget \ packages of the machine where I developed my robot and I copied those folders that had errors in Production. For example: if my error was UiPath.Activities, then I would go to the path described in the Development environment, look for the folder with the same name and paste them in the same path but in Production. That solved my mistake.

Another solution that worked for me was that before I was trying to upload the third party packages like (Bala Reva, Microsoft Word Interop packages) to my orchestrator libraries, but I could not find some packages in the default path( which can be checked from going to Uipath Studio-> Manage packages-> Settings-> The local default path to all your dependencies (Mine was C:\Users\USERNAME\AppData\Local\UiPath\app-21.4.4).
So then I went to C: \ Users \ USER_HERE \ .nuget \ packages and then uploaded all those packages that I have used in my libraries in the orchestrator and could not find in the default path and then cleared all my temp files(RUN-> %temp%) and then ran the process again from my UiPath Assistant and this resolved my issue and I did not get any error after that.