Issue in using On Element Appear

i_planned
studio
error

#1

Hi,

I am using an On Element Appear as a dynamic wait for a button to be visible and clickable before the process actually clicks on it. I left the TimeoutMS blank so it waits a default time of 30s.

After executing the process, the function did what it was supposed to do, wait for the button I identified to appear and clicked on it.

But after the step was completed, the process threw an error saying “Activity timeout exceeded”.

1

1

I’d appreciate it if anyone can tell me what I am doing wrong for this function, or if I used the wrong function to begin with.

Thanks.


On element appear - why is the default for the property RepeatForever TRUE
#2

Try with RepeatForever = false.


#3

It worked! Thanks a lot!


#4

Thanks. You saved my day.


#5

@ovi , @badita
Any idea why is this RepeatForever property is set to True by default ? In which scenario we actually need to Repeat Forever and ever !


#6

Given the fact that we’ve seen that this property is most used when False, I think it’s best to have it like that by default. Thanks Bejoy for the suggestion!

@Cosmin_Ion_Nicolae please consider this


#7

Glad to hear that! Surprised to know no one till now bring this to your notice. Thanks for the consideration.

This default value causes unnecessary error, i spend quite some time with this error, as it says timeout exceed i spend time thinking increasing delay time or something like that could solve the error. But no.
It finds the element does the activity in the do section and then throws this error, kind of a weird issue to debug. Hope this suggestion will be considered soon.

Really Appreciate the support. Cheers.


#8

Hi everyone, I am trying the vanish function we have withing UiPath and I need to check if a element vanish but the time out just predefined by UiPath is not enough. Is there any way we can change it?

Thanks in advance.


#9


Errori while using on Element Appear activity:

Could any one please help me in proceeding by fixing this error.
As disscussed above i have changed RepearForever=False, but still didn’t worked out

My selector is :
“”

please correct me where i went wrong


#10

Same error I am also getting


#11

Your selector is not visible in the post do not use quotes. Apart from this your selector should be like this


#12

Yes Joshi, thanq for your prompt response. I have declared the selector in the same way.

The thing is i am storing the above selector in an variable and then calling the variable in the properties window.
Then the issue is solved.

If i am declaring the above selector directly in the properties window , the problem is persisting.


#13

Use below selecotor with quotes:

webctrl aaname=’+in_TransactionItem+’ tag=‘SPAN’ class=‘page-numbers current’ /

IT will definitely work with repeatforever as false.


#14