Issue in publishing package *The operation has timed out*

Hi All,
image
I’m facing the issue in publishing the package, please help on this.

Regards
Ariv

1 Like

Hope this could help you buddy

or still the error persists
kindly contact the support team Error: Publish of workflow project to Orchestrator failed. The operation timed out

Cheers @arivazhagan_mathivan

Hi, I have the same issue (timeout), but only with a specific project. All other are working fin to publish in orchestrator… It worked with this a while ago - but then I made some small adjustements and now it does not work any longer. It’s just one main.xaml - but pretty complex and using Microsoft & Google Vision activity packs.
Any idea here?

Try to reduce the size of the Directory of the project. When you publish ALL the content in the directory is packed and the max. package size is somewhere below 24MB. So if you have Videos, Pics, PPT or something in this directory (and subdirectories) - remove it. Just let the necessary stuff in.
For me this worked immeditately.

3 Likes

To add on to what you’ve stated here, in the event someone else such as myself finds their way here… If you’re using the ReFramework, it by default takes screenshots of errors, so I had a folder of 40-50 screenshots from my development. This was attempting to upload along with the package. This issue is 9/10 times going to be pictures/videos/etc as @Ludwig_Wilhelm stated.

2 Likes

thanks, it worked for me

Hi Ariv,
the real reason for not getting Project published is related to execution. After making changes to Project, UiPath expects you must run Main process once successfully locally on StudioPro, before publishing Project. After one successful Run, you should not get any issue in Publish.

Thanks,
Amit Bordekar

Thanks, this info helped me