Irregular issue with Get or Move IMAP Mail Messages

Hi folks,

We have about 20 processes running on the Orchestrator for several months now, but we are experiencing a disturbing issue for a couple of weeks now.

What we know and have checked so far:

  • The processes involving the Get IMAP Mail Message or Move IMAP Mail Message activities sometimes encounter an issue, the others (without these particular activities) don’t.

  • When such an issue is encountered, the involved processed keeps seemingly running, but doesn’t do anything at all. It seems it is stucked inside the mail activity, since the log message supposed to be displayed just after the activity never shows up. There’s no error message in most cases, and I have to manually kill the process, otherwise it could last for days.

  • A process can run normally for several minutes (5, 15, 30…) and suddenly will encounter the bug. From here, it will be stuck forever. The amount of minutes before encountering the bug seems random.
    For instance, a process can successfully get mail messages from mailbox A, then will do nothing for ages for mailbox B. If then I kill and relaunch the same process, it can successfully get mail messages from both mailboxes, without any changes from me.

  • In a few cases, the process will catch an exception stating “Unable to read data from the transport connecton: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”

  • The IMAP activities use the 993 port and the right server, there’s no change about it compared to the previous weeks when everything was working fine. I wanted to test the process with Exchange activities instead of IMAP, but couldn’t achieve it unfortunately…
    Plus, we’ve checked the firewall, the server connection and server load, and nothing suspicious here…

Has anyone here experienced the same issue or would have a clue about what to do or what to check?
We don’t know if it could be an Orchestrator/UiPath issue, or an intern server problem. The weird thing is that a process can start working just fine, and then suddenly and randomly may start doing nothing without any log or error thrown.

Thanks for the help!


Hi @Remi_S

Have you already tried to update the Mail activity package to the most recent one? It would be the first step to try and see if this would fix it.

1 Like

Hi @loginerror,

Thanks for your reply.
Yes, I made sure that the processes already use the last version of the package (1.2.6863.29868).

Hi @Remi_S

have you found a solution to your problem? I’m having the same issue :confused:

would be super happy if you can help!


Hi @CP_automation,

Turned out it was not related to UiPath in itself, but rather to a network issue. We did a lot of tests with the UiPath support teams on my workflows and activities, and they didn’t understand either what was going on.
After a couple of weeks, the company in charge of the network at my workplace finally changed something (?), and it totally solved the issue.
Unfortunately, they kept that quite secret, and we were not able to have a precise feedback of what was involved.

So if you encounter the same issue, my advice would be not to focus only on UiPath, since it may be a larger problem…


hi @Remi_S

Thanks a lot for your answer! I hope i can somehow solve the issue then… lets see!


Im still facing this issue - already tried everything connectionwise… its a really frustrating problem since it is completely random and irregular for me as well while it used to work fine before…

Hi @CP_automation

In this other thread someone has just posted a confirmation of a potential solution:

Could you give it a try?

1 Like

Hi @loginerror,

My Robot is now an administrator, and also changed Proxy Settings, now the robot can read IMAP mails again!