GET IMAP MAIL MESSAGES DOESNT WORK

Hi everyone,
I hope that anybody could help me and explain the issue.
Well, when I run the project, in get transaction data I puted an activitie Get IMAP Mail Messages to get mails of GMAIL. Yesterdays It was working well. But today, I dont know what happend. In the activitie mentioned is loading and loading and loading and never stop or show me any messages. It happens nothing. I changed the correct password of the gmail to incorrect password to see if the activitie show me any error messages, but not. Do you have any idea? Is it a services problem? why?

1 Like

Hi @Pinto2019,

I think there is a bug in uipath interaction with Gmail, the same happend to me with send STMP message, the solution I am currently using is forcing a time out using parallel activity.

Regards

Hi @YAZIDI, you are using parallel activity just to detect when the activitie is taking long time to do right?

Hi @Pinto2019,

I am using it to throw an error if the activity take more than the default time out.

Cheers

1 Like

what is the other activity which recognize that get Imap is taking more time?

this is the only activity that I encounter. could be wrong tho.

hi,

try updating your mail.activity package using manage packages to the latest version.
it should work.

1 Like

I don’t know if this is the solution, but it worked for me. I killed all the Uipath’s processes (Studio/Assistant) and try again.
hope to be useful.