Invalid UI Node in son tab webpage

Hi all!

I have a coding problem. I have a bot which fills in a form from a public administration institute. The web of this institute is quite old and recomends its clients to use Internet Explorer.

Of course, I am not using IE in my bots. I have tried with Edge and with Chrome but I still have the same problem with both of them. The question is that to go deeper in the form, the user needs to click on buttons that open temporarily new windows that have the same name as the first, not the same url, but the same name for Uipath UI Explorer. So, it comes to a point when the bot cannot identify a new button that I need to click in. It may identify it, but as soon as I try to verify the selection, it changes to a different set of selectors resulting in a green OK Validation in the UI Explorer, but leading to a wrong button selection at the end (it would select a button in the original tab from where the new one I was trying to work on, was originated).

I have tried to fix this problem by closing the initial tab. In this way, I have only one opened tab in the browser. But now I have a different one. When I try to select the button I am interested in, in this final unique window, the UI Explorer tells me that the selection is valid, however, when I run it in debug mode, it comes out an error “Invalid UI node error” when the bot arrives to this point. Even at that moment, if I open the Ui Explorer, it says that the selectors are valid, and it is even able to markdown the button external limits.

So, my question is, if the UI explorer says that the selection is OK, if it marks the button limits, why do I have this “Invalid UI node error”? How can I avoid it?

Thank you very much for your help.

Cesar

This is the markdown of Uipath Ui Explorer. It marks the exact spot.

imagen

And this is what comes out when I open Uipath UI Explorer in the clic activity. You can see the green color in the upper left corner stating that the selection is correct.

Can anyone help me? It is a very tough problem and I cannot figure out how to escape from it…

Thanks a lot in advance,

César