Interesting SAP Error

Hello Community,

I have a very interesting SAP behaviour. I want to read data from different fields of an SAP screen. All works well so far. But in one case I get an error. I want to read data from a GuiShell with the sub type TextEdit. The text edit field contains 21106 characters. If there are fewer characters it works, e.g. 500.

The access to this field via Get Text crashes the SAP GUI for Windows 7.50 PL 8 HF 1 and the SAP Logon.


It makes no difference if i use try catch, the access to this field crashes the local SAP environment totally. I assume that has nothing to do with UiPath. Has anyone observed a similar behavior?

Thanks for tips and hints.

Best regards

Hi Stefan,

I haven’t face any use case before, however as per my knowledge, below can affect.

a.) Maximum capacity of variable, you are using to store text.
b.) Visiblity factor (simulate click)
c.) SAP element dependency if any.

Work around can be

  1. Perform click
  2. Using hot key Ctrl + A to select all
  3. Copy Ctrl + C
  4. Set to clipboard, and then get into variables using get from clipboard.



Hello Roma,
thank you very much for your reply and your work around, works perfect :+1:
Best regards

Hello Community,
very interesting the result of my error analysis. This morning I tried the same procedure with SAP GUI for Windows 7.60 PL 0 and the same error occurs. It seems to be independently from the SAP GUI for Windows version. If a text edit control contains more than 16702 characters this error occurs. If it is less, the method to get the text works without failures. So it seems better to use the work around from Roma generally, if it is necessary to get the content of an SAP GUI text edit control.
Best regards

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.