Installing new OCR Language

I have been trying to add Swedish to Tesseract OCR according to this tutorial: https://studio.uipath.com/docs/installing-ocr-languages

However, the installation location has changed with the latest version of Uipath Studio and the tessdata folder doesn’t exist in the new install location.

The new location for the Uipath installation is:
C:\Users[username]\AppData\Local\UiPath
But the tessdata folder isn’t there and there’s no sign of UiPath in the Program Files directories. So where do I put the new language files?

I am currently running UiPath on a PC with Windows 10.

Hi @manderss

Welcome to uipath community
well may i know what is the folder path that you have saved now with the new language installation file, as it should be done with file in the tessdata folder of the UiPath installation directory ( C:\Program Files (x86)\UiPath\Studio\tessdata ).

and this would be here only buddy, thats fine

Cheers @manderss

As I wrote earlier, C:\Users[username]\AppData\Local\UiPath is the install location for UiPath but tessdata does not exist in there.

There are no UiPath files in C:\Program Files (x86), I installed with the default install location when downloading the latest version of UiPath.

Hi @manderss,

The location has indeed changed (we will update the documentation, thanks for bringing it up).
The tessdata folder now resides in C:\Users\<user>\.nuget\packages\UiPath.Vision\<Version>\build\tessdata

The Version could be anything from 1.3.0 to 1.6.0 depending on what Studio & UIAutomation you have installed in your project.
The best way to determine this is to check the dependency for UiPath.Vision of the UiPath.UIAutomation package inside your project. (See the image below)
Most likely you will only have just one package version :slight_smile:
image

Let me know if this helps.
Cheers!

1 Like

This worked! Now I’ll just have to move on to experimenting with OCR scale and profile settings. Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.