Image exists does not time out?


#1

Hi I am doing citrix automation, and having some issues. The process is to enter a code check for errors > continue. To check for errors I tried OCR, which works, however throws an exception after a while in for each loop. I also tried, image exists, which works however a lot of the times it does not timeout within the specified timeframe 3000, sometimes it works and sometimes it does not. Any suggestions ? I have tired it on 2 different computers and having the same issue with image exists, which is my preferred method. I am using 2016.2.6155.


#2

The OCR issue has a workaround here: UIPath has stopped working - OCR

Image Exists may give late timeouts…as it takes about 7 seconds (on my laptop) to search the entire screen once. If it starts again at timeout-1s it will end at timeout+6s and only then throw the exception. Is this your problem?
It will be solved in a later version.


#3

Thanks @badita. The issue is that it sometimes it can take minutes to timeout. I have 2 laptops, one is with Intel graphics card and the second one is with Nvidia 2gb card, I thought that having a better graphics card would help, but in my case it does not, it still takes minutes in some cases on on the better laptop, both machines are running win 10 and same version of Uipath. If it took a maximum of 7 seconds I would be happy with it. Any idea why it takes minutes ?


#4

It should not happen, it seems to be a regression. We’ll investigate.

Thanks,
Mihai


#5

I am also having problems with timeouts not working.
I am extracting some data from SAP.

    • I am using UiElementExists
    • I used a ten second timeout
    • the robot waits for 5 minutes or more … just does not want to timeout ?

Perhaps this is something peculiar to SAP ?

All ideas welcome.


#6

@badita Do you know if still exist that problem? because I’m also working in citrix and looks like the image exists timeout is not working …