I want to upload a file to a site with the Edge browser, but it doesn't work

I want to upload a file to a site with the Edge browser, but it doesn’t work.

Here is the process.
(1)Press the “Select File” button on the system.
(2) Explorer opens. Search for a specific folder and enter the name of the folder.
(3) Enter a specific file name in the folder
(4)Select the specific file
(5)Click “Open” button (Upload)

A: A certain site opened in the browser
B:Explorer opened by A (windows folder system)
C:Folder where the file to be uploaded this time is saved
D: File name

Currently, (1),(3) and (5) can be done, but (2) and (4) do not work.

I have tried the following.
For (2)
When Explorer opens, [Alt + d] opens the address bar → Success
Set C as a variable in the clipboard and [ctrl+v] → Failure

For (4)
Even if D can be entered in ③, for some reason, another file is clicked and uploaded.

When the Explorer window appears, you have to Use App/Browser for it. It’s not part of the actual browser, it’s a separate window/application.

1 Like

Thank you for your answer.

I am sorry for the lack of information.
Currently, we use the browser type for browsers.
And Explorer is already treated as something other than a browser.

As for (2), I have tried two after opening the address bar with [alt+d].

  1. set C to the clipboard, [ctrl+v] and then [Enter].
    → Go to the next activity without being typed.

  2. without putting C in the clipboard, [ctrl+v] and then [Enter]. Specify the address bar as the input point.
    →The input is executed. However, Enter is not pressed and the current folder remains.

Translated with DeepL Translate: The world's most accurate translator (free version)

Keymu, can you send me your .xaml file so I can see what you’re doing? I can help you…

1 Like

You can provide the full file path in the ‘File name:’ field and click Open button. There is no need to navigate to address bar with [alt +d] or click on the file name.

Your steps would be:
(1)Press the “Select File” button on the system.
(2) Explorer opens. Type full file path name into File name: field
(5)Click “Open” button (Upload)


Thank you @grkiran2! that worked for me.

1 Like

Hello @Keymu

Instead of using ctrl+v, you can try giving the full path of the file using TypeInto.

You can try to record it using App/web recorder as well to choose different frames. Also the file name providing in the file explorer should be the full path.

1 Like

I found all of your responses helpful.

Among them, your answer solved the problem instantly …

Thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.