I have an issue,can some one please help

Scenario : I need to loginto to an application
when I tried to use type into activity for the username , It skips the first letter and types the remaining ones hence I am not able to login to the application :

Solutions tried : 1)gave a static delay before the activity for more than a min
2)set the before and after delay property of the activity
3)used the simulate type, click before typing, delay between keys nothing workded
4)tried the set text activity still din work
5)I used the get text activity to see what exacty is typed in the username and if it matched the username I provided, I gave an if condition to type the password , and in else condition I used the set to clipboard and send hot keys ctrl v,

but I got this error when I run through orchestractot

Get Text ‘INPUT ctl00_ContentPla…’ : The UiElement is not initialized"

what does this mean ?

Hi Renuka,

Try using element exists to check if the field is available and then try type into to enter user name.

For temporary workaround :stuck_out_tongue: 1. you can try using two consecutive type into activities which enter user name or 2. Add space before user name which is to be typed as it is skipping the first letter.

Regards,
Rahamtullah

Thanks for your reply Rahamtullah, as of now I gave Delay and delay between keys as 1000 with simulate click option ticked and its working but I don’t understand why was I not able to use Set text , get text and send hot key ctrl v

“Send hotkey ‘INPUT ctl00_ContentPla…’ : The target Element was not specified for this activity. You should set its Target property or use this activity inside of a scope activity (Attach Browser, Open Browser, Open Application, Attach Window, Get Active Window, Element Scope activities).”

Please confirm if you have specified element/selector where ctrl+v should paste your data.

I did…i gave the selector also

@RenukaRPA - When you are opening the login page of the application, check if the page/window is completely ready (using Target.WaitForReady as ‘Complete’) before you use the TypeInto activity. Please try this and let me know if it helps!

the issue solved, by giving the click before typing and delay between keys as 1000, thanks all for responding

@RenukaRPA - Glad to know you got this resolved! :slight_smile: