I get an error when I try to read the files I downloaded via http request

I need to download 2 files with http request. I don’t face any problem while downloading in my project. I just have a problem opening files. I would appreciate it if you could help.
RpaChallengeDiffucult.zip (29.9 KB)

Required website:https://developer.automationanywhere.com/challenges/automationanywherelabs-


required website… thanks for help

Can you please mention the error you got while reading those files


Sreejith S S

I am getting error in read range because excel files are not working correctly. Thank you for your help…

Mert Samet

@Mert_Samet_Sonmez if you got the solution please close this topic


Sreejith S S

no, I still haven’t found the solution, if I had found it, I would have already finished the topic. I still don’t know what’s wrong with reading range…

You need to wait until you make sure the file is downloaded completely and then read the file.
Also try using excel application scope activities if workbook activities didn’t work.

i don’t really know how to do it and i am waiting but still read interval activity is giving error if you can can you do it?

Thanks for help
Mert Samet

Hi @Mert_Samet_Sonmez
I had this error once because the file path i was providing was not correct.
Can you check the file path?

I can summarize the file paths correctly, I created a datatable and I can’t even open this datatable, so both my excels are wrong…

note: here it says that the file extension is not valid, it gives an error, but xlsx is a correct extension, I tried csv, it didn’t work.

Mert S.

So I think the error of the reading range is actually due to the file not being found, what do you think I’m doing wrong?

Can you try with a .xls file?

i got the same error again sorry

I fixed the problem, thanks all!!!

What was the issue?

the problem was related to the link, I renewed the links and it was fixed

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.