Reading excel (.xlsx) file from Orchestrator Storage bucket

When I initialized the robot it was working fine. The file was picked up from the orchestrator and table was read correctly.

then I had to modify the table slightly. changed the number value in a cell. very small change. Now I get various types of errors like:
Read Range: Specified argument was out of the range of valid values. Parameter name: zipFileName
Read Range: Unable to read beyond the end of the stream.
Read Range: File contains corrupted data.

The file wasn’t saved in Office 365 in the meantime.

Has anyone come accross and can help?


Open the excel file in local and then use save as and save the file again and try using it…looks like file is corrupted

It would be good if you can copy the data to new file and svae as well

Hope this helps


Hi Anil,

unfortunately it did’t help. I re-uploaded the original file then it worked, yet when I made a slight change in one cell it was corrupted again. I guess it’s maybe the excel version that the original file was made on but I’m not sure. I checked that for me it’s always corrupted now when I create on standalone or when I create on Office online. I think it must be some bug. as a workaround I changed the robot to read multiple csv files instead of csv and the problem solved (but this is only workaround)


1 Like


Instead of read range excel you can tey with read range workbook also…and workbook reated activities that might solve the issue