I can't connect UIPATH with Google Sheets

Hello everyone!

First, I apologize if the text is not in accordance with the language. I do not speak english. I’m using google translator.

Let’s go to the project.

In my integration I need to access data from a spreadsheet that is allocated in Google Sheets. It turns out I can’t make the connection. I have tried all the ways without success.

I downloaded the Gsuite add-on and installed it on UIPATH. Using Scopo from Gsuite I have already tried to connect separately through APIKEY, OAuth 2.0 and also through Service Account. But all to no avail.

Using APIKEY I get the feedback I need authorization from OAuth 2.0. Doing with OAth 2.0 always has the same answer that the targeting URI is not in the list of authorized URIs. Even registering the informed URI, the next attempt appears the same answer but or another URI.

where does the error occur? Is there another configuration had to do?

here using the OAuth 2.0.

Thank you so much!.

Depending on what you want to do, you cannot use API key authentication when working with Google Sheets. In this case, please use OAuth.
Please check this thread for a sample project that shows how to configure and use the G Suite activities with OAuth authentication: GSuite - Gmail Activity Unauthorized client error
Let us know if you still have problems after trying this sample.

2 Likes

Hi Mateus_Cruz!! Thanks!!!

In one of your answers, in the topic you suggested to me, it is said that OAuthClientID is highly recommended for assisted integrations. Right? In my case this would not suit me. Therefore the most suitable for my project would be ServiceAccountKey.

However, I made several attempts and was unsuccessful. I even followed his walkthrough and noticed that I had not enabled Drive API, had only enabled Google Sheet API. See below the error that occurs:

Thanks again for your help!!!

When you use Service Account, it’s like you are creating a separated account for the application using the service (in this case, a separated account for the robot).

So, if you want to allow the robot to access a Google Sheets document from your personal account, then you need to share that document with the Service Account’s email. To do that, you need to go to the document, click on “Share” (upper right corner) and then input the email of the Service Account you created.
A sample showing this in the same post I linked before (GSuite - Gmail Activity Unauthorized client error).

Also, please note that some services, like Gmail, won’t work with Service Account unless you have domain-wide access enabled. The reason for that is that, although you can share documents or calendars with the Service Account, you cannot share your email account. However, if you have domain-wide access enabled, then the Service Account will be able to impersonate you and use your Gmail account.

1 Like

Mateus_Cruz

Thank you very much. It worked, that was what was missing.

A lot of success for you!!! Thanks!!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.