I am trying to navigate to Insert->text->signature line in Excel sheet using recording tool.I am getting anc

I am trying to navigate to Insert->text->signature line in Excel sheet using recording tool.I am getting anchor based tag saying that selectors are not reliable.I ignored that and when I ran the bot,Its saying elementnotfound exception:clickongrid.

Can you please let me know how to proceed with this?

I recommend you not using recording.
Sometimes it’s not accurate well.
Instead, how about using excel activity?
There are many activities regarding write in excel, sheet, or anything else in excel namespace.

1 Like

But how can I click in Insert ->text->signature line without record activity?Also,my excel file gets changed every day,so the recording also fails.I dont know how to really proceed with this

The menu bar in excel that contains FILE,HOME,INSERT,…FORMULAS,VIEW.

In INSERT ,I will have a dropdown and in that I will click on Text,drop down appears and i will go to the signature line.

I see.
How about using send hotkey?
Alt + N + G is the activity you want.


Send Hotkey for such tasks, that will be more reliable. Avoid recording, add activities manually one by one as you go along with the steps. You can get the shortcuts easily for excel and if not, then you can just use tabs to reach the specific option.

And if we get an error stating “Selectors not reliable” so we need not to ignore it. That is because the selector has not got all the information to recognise that element. So in that case, we need to correct the selector until it validates.


Thanks.That works.But that doesnt open the signature setup box.I need to press enter to open the signature dialog.when i use hot keys and give enter,it doubleclicks and closes the signature setup box and creates a empty signature. Do you know how to solve this?

How about use arrow key?
Alt + N + G + ↓ + k[enter]

But this will go into the next below option and open,“add signature services” which is below the microsoft office signature line

Is it run alright that separating send hotkey activity?
Send hotkey : Alt + N + G
Send hotkey : ↓ + k[enter]

I tried this too.it just creates empty signature and closes the applciation.

Did you set ‘indicate screen’?
And did you use ‘type into’ activity to send multiple hotkey?

I did not use indicate screen.I tried doing that but the element disappears(“microsoft office signature line”) when I use indicate screen.

Hi @suchitra.nagarajan

Signature.zip (39.9 KB)

I have tried achieving what you are trying to do by all the ways that I can think of and it worked fine for me. Attached the workflow, just have a look and see if that helps.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.