I am facing issue with starting job using Orachestraor API

Thanks a lot this was very very helpful and resolved my issue. Next I am facing issue with starting job using Orachestraor API.

odata/Robots gives me empty response:

{
@odata.context”: “https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/$metadata#Robots”,
@odata.count”: 0,
“value”:
}

Hello @rajkiran.vajreshwari!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Hi @rajkiran.vajreshwari,
Could you share the details? How looks your API Call? Please just anonymize sensitive data if there is any.

Hi Pablito,

Thanks for you response. Here is my APIs call sequence.

API Call 1 | Get token : https://account.uipath.com/oauth/token

API Call 2 | Get Process release key :https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/Releases?$filter=ProcessKey eq ‘BlankProcess’

{
@odata.context”: “https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/$metadata#Releases”,
@odata.count”: 2,
“value”: [
{
“Key”: “104ce5df-5380-486a-9f71-XXXXXXXXXX”,
“ProcessKey”: “BlankProcess”,
“ProcessVersion”: “1.0.2”,
“IsLatestVersion”: false,
“IsProcessDeleted”: false,
“Description”: “Blank Process”,
“Name”: “BlankProcess”,
“EnvironmentId”: null,
“EnvironmentName”: “”,
“InputArguments”: null,
“ProcessType”: “Process”,
“SupportsMultipleEntryPoints”: false,
“RequiresUserInteraction”: true,
“AutoUpdate”: false,
“FeedId”: “87bd30cc-e088-4fc0-9245-YYYYYYYYYY”,
“JobPriority”: “Normal”,
“CreationTime”: “2020-09-23T02:55:26.057Z”,
“OrganizationUnitId”: 598628,
“OrganizationUnitFullyQualifiedName”: “Shared”,
“Id”: 164294,
“Arguments”: {
“Input”: null,
“Output”: null
},
“ProcessSettings”: null
},

API Call 3 | Get Robot Id : https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/Robots
Passing all the headers including OrganizationUnitId as 598628, but I am not getting any robot Id.

{
@odata.context”: “https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/$metadata#Robots”,
@odata.count”: 0,
“value”:
}

API Call 4.a | StartJobs : https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/Jobs/UiPath.Server.Configuration.OData.StartJobs

I do not know what to pass RobotIds, as Expected it errored.

{ "startInfo":
   { "ReleaseKey": "104ce5df-5380-486a-9f71-XXXXXXXXXX",
	 "Strategy": "Specific",
	 "RobotIds": [ 1234 ],
	 "JobsCount": 0,
	 "Source": "Manual" 
   } 
}

here is response.

{
	"message": "Couldn't find any unattended robot in the specified folder.",
	"errorCode": 1671,
	"resourceIds": null
}

API Call 4.b | StartJobs : https://cloud.uipath.com/thermgusrgik/thermofisheiv4n598144/odata/Jobs/UiPath.Server.Configuration.OData.StartJobs

Tried to call only with Releasekey and Strategy as ALL, without Robot Id.

{ "startInfo":
   { "ReleaseKey": "104ce5df-5380-486a-9f71-XXXXXXXXXXX",
	 "Strategy": "All"
   } 
}

here is response.

{
	"message": "The job strategy All is not supported in modern folders",
	"errorCode": 2815,
	"resourceIds": null
}

Hello!

It seems that you are using a Modern Folder, which does not contain Robots in the same manner as Classic Folders: https://docs.uipath.com/orchestrator/docs/robots-in-modern-folders

In the case of Modern Folders, you don’t need to specify the RobotID, but you should change the Strategy field to ModernJobsCount: Starting a job trhough API on a modern folder

Thank you, this worked fine.

Can you please provide suggestion, what is best approach - Classic folder or modern folder? especially when we deploy this to production?

I’d suggest Modern Folders, as they have advantages that make deployments much more scalable and easier to manage: https://docs.uipath.com/orchestrator/docs/key-features-and-behavior

Excellent thanks a lot. Appreciate your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.