Unable to to start job by using APIs from postman

Hi

I am using new Cloud Orchestrator, when I run the job manually from Orchestrator its running with out any issues.
But when
I am trying to start job from Postman using API I have to provide RobotId hence when I try to get robot id by using the below API it was told that the count=0.

{

"@odata.context": "https://cloud.uipath.com/XXX/PoCTenant/orchestrator_/odata/$metadata#Robots",

**"@odata.count": 0,**

"value": []

}

But when I try to fetch all the robots using “UiPath
it was given " ```
{
@odata.context”: “UiPath”,
"@odata.count": 2,
“value”: [
{

---
---}" 
I have tried to start the job by providing robotId from above API response but failed with below error
{
    **"message": "Could not find a machine with Unattended or NonProduction runtimes in the current folder",**
**    "errorCode": 2818,**
**    "resourceIds": null**
}

Please suggest how to fix  this in new cloud  Orchestrator .

Hi @Neerugattu
did u did all the configuring and autenication too before processing any api request to orchestrator api via postman

Yes…I did, that’s how I got folder I’d(OU), release key…etc.

Thank you