HTTP Request working in preview with Wizard, but not when executed

Steps: I’m having an issue with executing the HTTP Request activity. When I go through the initial HTTP Request Wizard and set up the End point, Request Method (GET), Accept response as (JSON) and Authentication as Simple HTTP. The API only needs a Username credentials and no password. Once I plug this information in, I use the Response to see if it worked and it will show the correct results in a JSON format.

Here’s the issue: Once I press okay to set the activity and try to run it, I get the error code {"error":"No API key entered in the password of the authentication of this request."}. Obviously, I have check this code in the website’s API documentation and it is a failure to provide the username, but when I run the API call using CMD and using the same endpoint and username I get desired JSON results. Again, this API doesn’t need a password, just a username.

I’ve tried using “” and “nothing” in the Password field on the Properties after the activity has gone through the Wizard setup. Also, removing the “” from the ClientCertificate and ClientCertificatePassword and nothing changed. I’ve added the screen shots of the setup and properties pane.

I’m not sure what else to do…needing some help on this.

Thanks for the input everyone; I really appreciate the timely replies. What a community!

1 Like

@Clayton_McKinney1

Welcome to our forum,
I would like to apologize for the delayed response from the community .

As per the website , of the api provider. API key provided needs to be used in the username field of Basic Authentication and I agree you that ,in Uipath you get to see 401 error code along with the response message {“error”:“No API key entered in the password of the authentication of this request.”}

I did find a workaround for your problem in UiPath. You would need to use Postman and then run the sample request from Postman first .

Postman would generate a header value like the one shown below

Copy this header value from Postman and paste it , inside your Options => Headers of UiPath as shown below

BINGO!!! You , are now guaranteed to get a successful response in Uipath , as how I got back a success response,as seen in below screen

:dancer:

2 Likes

I suppose another way would be to simply assign the string yourself, like so:

Nevertheless, I reported this for our team to consider for future versions of the Web package.

1 Like

Thanks much @loginerror for an alternative solution and also for considering to fix .

1 Like

@mzahid thank you for the reply! I really do appreciate the help. It worked!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.