HTTP Error 500.30 - ANCM In-Process Start Failure


Today I started to get this error message when I try to access my Orchestrator:

I dont even get the Sign In window.

Yesterday we renewed our SSL certificat in the IIS.
Could it have something to do with that?

Orchestrator version: 2020.10.2
Anyone have any clue what I can do?

Best Regards,

wierd issue but if you changed SSL maybe it is the cause.
Check the appsettings.Production.json file from Orchestrator/Identity folder, the SigningCredentialSettings > Thumbprint > Name, if it is not different from the Thumbprint/Certificate Hash of the Certificate, which should be the same.

If it is different, update the appsettings.Production.json , save the file, and restart the IIS website



It was indeed not the same thumbprint.

I changed it in the appsettings.Production.json

I can now access the Login page but when I sign in I get “This page isn’t working”

If I then press “back” i get inside the Identity Management /Hub but if I click anything it doesnt work.

Thank you.

Hi again,

I tried with another SSL certificate and changed the thumbprint again.

Now it works, Thank you so much @pikorpa you saved me some major headache!

Thank you!

Just a side question, why did this happen @pikorpa ?

Should not the thumprint automatically update in the appsettings.Production.json file?

To be honest I don’t know why it happening.
I used to have a problem with the Orchestrator after SSL update and that’s where I found the root cause.

1 Like

Nevertheless thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.