How to validate Selector for "Save As" click activity in assignment 2

Hi,
Please anyone can suggest to me how to validate the selector for “Save As” -click activity in assignment 2. I have tried all methods but not working. This is what I am getting all the time. My entire project is working properly, but out of 13 entries, it is only completed for 8 entries. like this,

  1. Completed
    2.Open
    3.Completed
    4.Completed
    5.Open


    Anyone can help me with this?
    Thank you
1 Like

@Harshit0
Hi.

The selector may not be the cause if there are successfully completed entries.

Use “Activate” to activate Frame Notification Bar before clicking the button.

Thanks.
-Tera

1 Like

@Harshit0

Welcome to our uipath community.

Place those activities inside Attach Browser activity and give it a try once.

2 Likes

Thank you for the reply @tera
All WI4 entries are not successfully completed. I am getting this type of error.
And also how to “Activate” frame notification bar??

1 Like

Hi,
Thank you for your response @lakshman. I tried using the attach browser and attach the window but not working.

2 Likes

@Harshit0

May I know what error are you getting here ?

And also show me screenshot of that Attach Browser Activity and need to check once how you placed all required activities inside

2 Likes

@Harshit0

There is an “Activate” activity to activate.

1 Like

I have attached the screenshot of the selector and the activity. Also, I have attached my workflow for creating a yearly report.

System1_CreateYearlyReport.xaml (38.1 KB)

1 Like

@Harshit0

Try this with the “Save As” selector
selector.txt (196 Bytes)

1 Like

thanks, @tera I have used this for the first click activity and its validated but what about second click activity (the one that I have mentioned in my first question)in which we are using F2 for the delay and then selecting SAVE AS from the drop-down menu?

@Harshit0
I am sorry,I finally understand the intent of the question.

Please “activate” before clicking or substitute with hotkey

@tera, Sorry but I have tried “Activate” before click activity but still have the same issue. Can you please look at my workflow, that I have attached below and please explain it to me where I went wrong. ? ThanksSystem1_CreateYearlyReport.xaml (39.8 KB)

This is the error I am getting for click activity.
Click Save: Cannot find the UI element corresponding to this selector: <wnd app=‘iexplore.exe’ cls=>‘IEFrame’ title=‘ACME System 1 - Reports - Download Monthly Report - Internet Exp*’ /><ctrl name=‘6’ role=‘drop down button’ /