How to uninstall java extension?


I apologise in advance as there is probably a simple answer to this, but I cannot find it.

I have been using UIPath Studio to automate some processes in a third party Oracle Forms application. Everything had been working fine until for some reason, when creating some new activities, I received a prompt which said something along the lines of

“It looks like you are using a java application. Would you like to install the Java extension?”

Without really knowing what I was doing, I clicked Yes. Since then, the sequence I had created, which basically just logs into the Oracle Forms application and clicks through a few screens, has stopped working.

A quick google returned the following:

“To check if the extension is not working properly, open UIExplorer and try to select controls inside a Java app. If the entire window is selected, it means that the extension is not working properly.”

This is exactly what is happening to me.

So my question is, how can I uninstall the java extension and go back to the way things were before?

Unless I am missing something obvious, I can’t see anything in that article or elsewhere which explains in simple terms how to remove the java extension.

In UiPath Studio, if I click on Tools, the right hand pane is headed Extensions and there is an option for “Java extensions - Installs the runtime plugin for automating Java-based applications”.

If I am still getting the option to install it, does this mean the java extension perhaps hasn’t been installed correctly?

Can someone please tell me how I can get my UIPath project back to the way it was before I clicked “yes” on that popup window?

Thanks in advance.

Hi @jamesyreid,
I think you will find some helpful information here:


That’s exactly the same article I mentioned in the original post!

Unless I am missing something, it doesn’t say how to actually remove the extension.

I’m sorry, I was reading this through raw text (without links).

Anyway in this link there is a part:

Using a text editor, such as Notepad++, open the file, which is located in the C:\Program Files (x86)\Java\jre1.8.0_xx\lib folder. If the extension is properly installed, the file should contain assistive_technologies=UiPath.UiPathBridge.

So I’m just guessing that you need to put # before mentioned line and extension should be disabled.

Eventually after installing Java extension automatic backup of this file is being made. You can just remove current and rename this which was used previously:


I have various different JDKs and JREs installed on my PC. I’ve searched through them all, but none of the files were updated recently, and none of them contain the text “UiPath”.

I did find UiPathJavaBridgeV8_x64.dll under C:\Program Files\Java\jre1.8.0_92\bin, and UiPathBridge.jar under C:\Program Files\Java\jre1.8.0_92\lib\ext (my JAVA-HOME is currently set to C:\Program Files\Java\jdk1.8.0_92).

I tried deleting both of these files (having taken backups of them first), and then reopened UiPath studio, however it doesn’t seem to have made a difference. When I try and select something in my Oracle Forms application, the entire window is still selected.

Any other suggestions?


You can try to check settings in Java Control Panel. Maybe there is something related to this extension which should be removed/disabled.

I had a look there but couldn’t see anything obvious. I did however try deleting the temporary internet files from the Java control panel.

I’ve just tried installing a new Java 8 JDK and making it my JAVA_HOME, however that hasn’t helped either.

Is there anything I can clean out / reset in UiPath explorer? I’m not sure how it links itself to my JAVA_HOME.

I started to digging a little. Please be informed that it’s not anyhow official way (just only my thoughts/experiment).

You can try to run regedit and go here (the last key will be the date when you have installed java extension):
And try to change this entry value for 0:

isInstalled was already set to 0.

I tried deleting everything under JreRegistry (after taking a backup), however when I started UiPath Studio again and opened my project, it is still selecting the entire window.


Hi @jamesyreid,

Oracle forms can only be automated with the extension installed. In case something went wrong when you clicked ok on the pop-up, can you run the java extension setup from studio? close any java application beforehand


Thanks, I think I am back up and running again.

1 Like

Hi I am facing the same issue tooo on installing the java extension , before that I used to get the selectors . now the entire screen getting selected . any solution on how to get this thing resolved

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.