Problem to launch Java application and to uninstall Java extension

Hi! I cannot launch a Java application from UiPath Studio. I can run it directly, but I cannot start it from my project using a “Using application” activity. I have also tried with the Classic model activity “Open Application” and i have the same result: the application does not start, and so, I cannot proceed to its automation.

I hace tried to uninstall my Java extension in UiPath, to install it later, but I have not been able to do so, because I receive this message: “Error no. 5. Uninstallation error”.

Can you help me to solve the problem? Thank you very much, Cesar


Try using Start process instead


Hi Anil! I have tried Start Process with the .jar file, and it results in a small window with a “Launching application” message, and it stops there.

However, it I doubleclic on the .jar file, the application starts well.

If I try to use the .bat file in the Start Process activity within UiPath, I get an error message from Java saying that it cannot find the marco.jar file (the one I explain before, I doublecliked on and work perfectly).

At the end, the point is taht I can launch it perfectly if I do it manually, but I cannot make UiPath Studio to launch the application. What can I do to solve this problem?

Hey @ccrespo9669 ,

Can you please check if you have enabled the java bridge in your os or not, if not please enable and try it.



Give the java.exe in process and pass the jar file as argument and check …

Also there are few settings to be done for java applications. Check the dll filea and place them
Properly in the java application folders


Hi! Thank you very much Anil and Sanjit for your answers.

I am able to select combo boxes, etc., once the java app is opened from my xaml. However I cannot open the app from the UiPath project.

I do not know how to search and set tha Java Bridge you talk about. I have read your article on trouble shooting, but I am not able to set all those points.

I wanted to start to uninstall the extension and install it again later, however, I cannot do it because UiPath returns an “Error no. 5 error unistalling”