How to skip "pick an account prompt" while uploading a file to Teams SharePoint using UiPath custom SharePoint activities

I was trying to upload a file to sharepoint using custom sharepoint activities by Radu. Everytime i run the BOT I am getting sign in prompt to Teams Sharepoint. Can anyone help me how to skip it and directly upload the file. The sign in prompt doesn’t show up when i try connecting to sharepoint manually.

Try to check with element exists (Activity-Element Exists) if popup is there or not. If existed close the popup with click activity else it will run with your code

I tried handling the pop up.The attached window and the click activities won’t work.

@radu_bucur
Can you please let me know if u are aware of the solution.

is it possible that you’re using WebLogin with Reset Credentials Checked? Like Below:
image
If so, either change the WebLogin Option to Online (so you can login with your email and password) or if you would like to keep using WebLogin uncheck reset credentials.

If Online mode doesn’t work for you and if WebLogin is doing what you described even if Reset Credentials is not checked, let me know we’re currently testing a new version of the package with a new login method implemented and I could share it with you and hopefully that will work

1 Like

@radu_bucur

Thank you for replying.

I have Reset Credentials property unchecked for webLogin, yet I am getting sign in prompt.
Business requirement doesn’t allow me to use UserName and Password in my process.
So if you could share the new login method that is being tested it will be great.

Thank you,
Apoorva

Sorry for the delay. Here’s the package with the new login mode, it will be added to the UiPath Connect shortly:
UiPathTeam.SharePoint.Activities.1.5.3.2.nupkg (108.6 KB)

You should use AppSecret auth mode for SharePoint sites for which you are able to create an app-principal . When you create a SharePoint app-principal you will obtain a Client Id and a Client Secret and you will use the two codes for logging in and the credentials are no longer required!

You will need Admin Access to create such an app!

2 Likes

HI @radu_bucur

Thank you for your response.

Using UiPathTeam.SharePoint.activities version -1.5.2 , few people getting sign-in prompt and few people not getting any sign-in prompt for uploading,creating and to copy the file from online share point.

Could you please let us know, is there any issue with the library package or is it anything missing from our end
and kindly let us know is there any other way to avoid sign-in prompt without using client id and client secret principal?

Please find below screenshot for your reference, we are not passing any parameter and credential but it was working fine for few people without asking any sign-in prompt

Best Regards,
Naveen Chaganti

Please download the package I uploaded here and use that one until we upload it on the platform. It’s still not released yet to the Connect but it will be soon

1 Like

Dear @radu_bucur

I am asking about old version which was exist in community -1.5.2.

Which was working for few people(i.e-1.5.2) and same not working for other people .

Best Regards,
Naveen

If somehow it doesn’t work its because of various different security configurations and environment differences, its not something that the activity version should impact.

@radu_bucur, Please find the below error which is occurs only sometimes when there is a windows update happens,

Timed out! You took more than 300000 milliseconds to introduce your credentials!.

We are using the Weblogin. the same code works in the dev machine but sometimes it’s not working the UAT machine with a different user.

Sharepoint Activity Version : 1.5.2

Awaiting for your response.

That is expected.
In order to avoid having weblogin get stuck, we added a timeout for it in 1.5.2. , which by default is 5 minutes (300000 seconds), feel free to increase it if you are getting that exception

@radu_bucur, Thank you for the response. even after increasing the timeout still having the same error.

note: this happens whenever there is an windows update and the robot machine is restarted.

@VijayaKumarA, did you find any solution for this? I am also experiencing same issue.

@radu_bucur - Do we have any solution for this? We are getting "Timed out! You took more than 300000 milliseconds to introduce your credentials! " error, I even tried increasing the time limit to 10 minutes but it did not work.

Hello. I think most companies will not allow the method as you describe above because if you are only using a client_id and client_secret to access SharePoint the app permissions would give the app access to ALL SharePoint sites when in actuality the access should be able to be designated to certain sites. What may be an interim solution is to somehow allow an unattended bot detect the weblogin window so that credentials can be passed to it during the login process. I’m currently attempting to have an unattended robot use the weblogon feature and detect when the MFA window appears and then enters the logon password into that window but for some reason, I am unable to detect that window during code execution.

Hi Radu, thanks for the SharePoint Custom Activities Package and specifically the WebLogin ability for attended robots, it is working great in my MFA environment when accessing a SharePoint 2016 instance. However that of course fails when attempting to access a SharePoint 2013 instance (use of passwords is no longer ever to be allowed again, so that eliminates the normal option). In this thread you had indicated a v1.5.3.2 that will implement app-principal - which is great but also something that will not be allowed in our environment. But it got me thinking that in PowerShell they implemented a -CurrentCredentials option (similar in use like -WebLogin) that does work for SharePoint 2013 with MFA. Is this something you may be able to look into and see about replicating that ability into your custom activity? That would be awesome.