Windows Authentication failure: UiPathTeam.SharePoint.Activities

Hi all,

Thanks in advance for looking at this. It is long, I have tried to include all details that might be a clue for someone! Double thanks for any ideas or suggestions!

Looking for any suggestions or thoughts on why the process to get files from SharePoint stopped working on Friday, July 23. There were not updates pushed to the OS on the bot host nor network updates - It stopped working too early in the day on Friday and it wasn’t a release weekend. It also stopped on both lower level, Stage, and Prod and updates would not push to both systems on the same weekend.

We’ve been running this process for around 1 year, maybe longer. It has been the most stable of all the jobs that run on this bot host.

This is a job that logs connects to an internal company SharePoint URL. It checks multiple folders for Excel spreadsheets. If a spreadsheet exists it makes a copy onto the bot host in a local folder (for other jobs to execute) and moves the file from submitted to in-process folder in SharePoint.

Now, the bot doesn’t get past authentication to SharePoint. The general error message is, “The sign-in name or password does not match one in the Microsoft account system.” The sign-in UID is a generic service UID in AD. The account is in a group that does Not require MFA

The same basic failure occurs when run directly in Studio (either 2019.10.4 or 2020.10.4), triggered manually from Orchestrator or run on automatic trigger from Orchestrator.

The robot is running on Windows Server 2016.

UiPathTeam.SharePoint.Activities 1.5.2 and 1.7.0 (different bot hosts, same outcome)

UiPath.UIAutomation.Activites & UIPath.System.Activities, both at 20.4.2

We have other packages for this process, such as Excel and Mail Activities, but I don’t think these are impacting the pwd fail for the SharePoint.Activities. I will update the packages all to the latest and try again…

  • We can connect as the service user with remote desktop to the bot host machine Same UID and same PWD.

  • We can log into Teams as the service user on the bot host successfully (no request for MFA)

  • We can login to Outlook as the service user on the bot host w/o MFA and send and receive email

  • We can browse to the SharePoint URL manually and login w/ the same UID/PWD w/o MFA in an Incognito Window.

It only fails w/ this error from UiPath, Studio or triggered from Orchestrator!

Any thoughts, suggestions or ideas?

20210726 SharePoint Test Fail - Crop

Thanks,
Tom

Here is a detail from the Log:
20210726 UiPath 00-ExtractAll Fail 00003-crop