How to set resolution on unattended bot when 'Login to Console' must be enabled


A problem keeps cropping up that seems like it should have a straightforward solution.

We need an unattended bot to run on 1920x1080p to work correctly. We also need to use hardware events as the software the bot is automating is so old.

The unattended bot runs on a Windows Server VM, so ‘Login to Console’ has to be enabled or hardware events will not work, as I understand it. However, if we do this, then we cannot set the resolution from the Orchestrator.

The bot then finds that when it logs in, the resolution is 1024x768, and this causes all sorts of issues. It doesn’t happen on every Windows Server though, so there must be a way of changing the default resolution that the bot will connect as.

Does anyone know how to do that please?

Hello @g.ward

If the application is set to maximize, is it throwing the error? Also whats the error that you are getting and is it for any particular activity?


The problem is that at 720p certain buttons or list items that the bot needs to click on (with hardware events) are not on screen even when maximised, and having to redesign the bot to deal with that would be no simple matter. Surely, there must be a way to keep it at the resolution it works best at!

Have you already checked the below post:


We have tried the Uipath.Settings method:

but no dice, even after restarting.

The other methods on that website are no good because they require Login to Console to be disabled.

It seems like there must be a default setting on the VM itself somewhere, and we just need to find it!

Hi @g.ward and welcome to the uipath forum

Once you enable the loginToConsole in Orchestrator, the Uipath.settings configuration is overwritten and is not applied anymore.
Now i already changed the resolution to 1920x1080px32 on my robots even with LoginToConsole enabled and that worked fine (Windows 10 OS machine)
Did you try to set the resolution with LoginToConsole enabled?

Hi Emira, unfortunately it always sets itself back to 720p no matter what order we do it in. In the past, logging into the RDP first before launching the bot has also fixed this issue, but not in this case.

Anyway, thankfully there’s been a misunderstanding on my part which I alluded to in the intro. In the documentation about free RDP sessions Windows Sessions (, I was confused over this section, where it says:

On a Windows Server, however, there can be an active RDP session for each user of the machine, or even multiple sessions for the same user. This means that multiple Robots can simultaneously execute processes on that machine, each for its designated user. In this scenario, Robots can also execute processes for a user on multiple sessions, but they must not rely on Hardware events (such as UIAutomation activities).

I read it as Hardware events can not be used for any free RDP session, but actually its only when the bot tries to login twice as the same user, which incidentally was the case the last time we tried this, so I had the wrong idea cemented in my head. Since then I’ve not even tried it, but it does actually work fine.

I think the question is still worth asking however - why do some server VMs launch by default 1080p anyway and not others?

1 Like

Man, for this, a better approach would be asking for the IT team to change the default resolution of the VM in the hypervisor.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.