How to run a process without UiPath Studio (and Orchestrator)

orchestrator
studio

#1

Is there a way to actually run a process without UiPath Studio (and Orchestrator)? I have been able to run/ schedule a process without Orchestrator with a .bat file and taksplanner but its not working when you only have the Robot installed. Does anybody have any experiences with this?


#2

Hello @ElectricBoogie
In fact UiRobot is enough to run processes from CMD, you just need uirobot to be installed and you can run the process from Command line using this command,

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe” /file:“full path of your workflow”

more details are in the link bellow

Also this will work if uirobot is installed in the directory described above in the commnad otherwise you have to give the right path to UiRobot.

hope this will help.


#3

Hey @reda,
Thank you for your reply!

I have tried this as well. It works with UiPath Studio installed but not with only UiPath Robot installed.

With UiPath Studio
16:41:04.0000 => [INFO] [UiPath.Studio.Shared.Logging.OutputLogger] [19] BlankProcess execution started
16:41:05.0000 => [INFO] [UiPath.Studio.Shared.Logging.OutputLogger] [20] Message from UiPath 16:41:06.0000 => [INFO] [UiPath.Studio.Shared.Logging.OutputLogger] [19] BlankProcess execution ended in: 00:00:02

With UiPath Robot installed only
16:45:52.9538 => [INFO] [UiPath.Studio.exe] [1] Set native thread language to LangId=0x0009
16:45:56.4616 => [INFO] [UiPath.Studio.Shared.MVVM.Commands.CommandManager] [1] Application.MainWindow is null, cannot subscribe to keyboard events, subscribed to Application.Activated event

Any advice?


#4

Hello again @ElectricBoogie
have you tried opening the UiRobot Tray in the machine where you don’t have Studio installed and run them from there?
image


#5

Hey @reda!

Yes this actually works with UiPath Studio installed.
Otherwise it will give me an license error. Meaning that it can’t be done without the UiPath Studio license.
Thanks for your help and advice!


#6

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.