How to dismiss the black screen that comes as if someone pressed the Windows key

On an unattended robot, before a bot executes, at random it sees a black screen, that comes when you hit the Windows key, (even though no one did). This is blocking the bot from seeing selectors on applications it launches and fails. I tried sending Esc as a hot key, which is supposed to dismiss this, but when run from within a bot, it does not dismiss the black screen. I tried several other things such as a separate bot just to send esc key and calling it from the parent bot with Start Job. Nothing works. The only time it works is if that is the only statement in a bot.

Has anyone else faced this and resolved this?

Appreciate your help.


Use send hotkey with

Should work. Remember to check simulate/send windows message option

Like I said, it works well when that is the only activity in a bot. But when I add this activity as the first one inside another bot that has more activities following it, the send hot key does not work. And that is the reason I created a bot just with this one activity, and calling it (with Start Job) within the bigger bot. Even then, it does not work, even though that is being called for sure.

You are right. UIexplorer does not allow you to select that pop up. I thought you could attach it


Use background automation.

Your clicks or type into make it with simulate property

Avoid hot keys…It will not give you assurance if it worked or not

Background automation should not have clicks, type intos or any activity related to using the mouse of keyboard or any other screen related activities.

You can simulate or send window message

I found the solution. When I call the process with Invoke Process (instead of Start Job) it works correctly and dismisses the black window.

I was browsing other questions on the forum and came across this Marketplace listing: Central Controller Template For Sequential Jobs - RPA Component | UiPath Marketplace

And on the questions panel, one of the responses mentioned about using Invoke Process for non-orchestrator processes, and it worked even for orchestrator based process. After all, a process exists only on the Orchestrator, right?

Long story short, using Invoke Process to call the process (just by name, no environment is needed unlike Start Job), it works like a charm.

Thanks to all of your responses and the clues.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.