RE: Unattended but working only when the screen is open

Hi Sir,

My bot is running even screen is locked but “Click activity” is failing always and it shows UiPath.core.selectorNotfound.exception…
Also I’ve tried both simulate and send windows message activity

For example, 1. Log activity 2. type into 3. click… Here 1,2 is working but 3 got error… How can i fix this

Hi @VelanDev

Please check the input mode for the click activity. If the input mode is other than chromium or else simulate then this type of error occurs and also please cross check the selectors for that click activity.

Regards

@VelanDev

check the thread

It’s already in simulate. But still selector not found exception error is coming… if system is on everything works fine.

Hi @VelanDev

Please try the below link:

Regards

Hello,

My desktop is not been disconnected, sir. It’s working with other activities and also click selector works properly when the system is on. When system is locked only click activity shows selector not found exception…

Tried sir. Same result.

@VelanDev,

Check the input method of the click activity if CV is used.

Thanks,
Ashok :slight_smile:

Hello @VelanDev

Can you confirm if you have installed unattended robot or you are using only attended robot installation?

Cheers

  • Automation processes that use UI Automation activities cannot run under a locked screen.

image

Reference: Activities - About the UI Automation activity package

  • Make sure you are not setting you automation project to Start in background.

  • Install the robot in Service Mode and before scheduling the job from Orchestrator, make sure that you log out from that user. This will help with the issue with disconnecting the robot.

  • For Executing Tasks in a Minimized RDP Window check Robot - Executing Tasks in a Minimized RDP Window