How to disable Azure Information Protection popup

Hello, I have encountered an issue where Microsoft Azure Information Protection popup appears while trying to save .docx file as .htm file:

I do not want to use ‘element exists’ or something to close this popup because I have noticed that in another environment this does not appear which means there is a solution (maybe some settings) where the popup does not appear. However, I cannot find what these settings are. In both environments the AIP Add-In is enabled.

I am using activity ‘Save Document As’ in ‘Word Application Scope’:

I have tried killing Word process after this activity but it never reaches that point because robot gets stuck on this activity forever.

Does anyone know how to disable this popup? Maybe there are some Word or user settings?

Hi @nespalvota

I’m not sure, can you give a try on the below steps

  1. Open the Azure Information Protection client on your computer.
  2. Click on the “Settings” button in the top-right corner of the client window.
  3. In the settings menu, select “Options”.
  4. In the “Options” window, go to the “User interface” section.
  5. Uncheck the option that says “Show Information Protection bar”.
  6. Click “OK” to save the changes.


Thank you Gokul, but unfortunately this does not help. The bar is not visible but the popup still appears when trying to close newly saved file.


  1. Try using read only property in word application scope and perform save as to see if that works
  2. These are rrstrictions made by the admin…so either he should be adding exception at user level or remove the restrictions
  3. Ideally aip addin should be disabled for this to work
  4. Alternately…you can use a click activity on it with parallel activity…and have continue on error trye for the click activity so that if it is not present process will move ormally and if present it would click…paralle activity will help in making click and save as work at the same time without making the bot stuck


Thank you Anil for your answer.

  1. Read-only is already used, thus, it does not solve this issue.
  2. That could solve it, do you know what restrictions should be changed?
  3. Yes, but we need the add-in for other reasons, therefore, we cannot disable it. In addition, this issue does not reciprocate in a different server even though the add-in is also enabled there.
  4. That is a workaround while I am searching for a solution. Also works to kill word process.


About azure restrictions your azure admin can help you with the exact restrictions to be removed at user level


Hello, @nespalvota,

  1. Set-AIPFileLabel (AzureInformationProtection) | Microsoft Learn
    Set using powershell, unless your org did not push it to virtual or user machines AIP module.
  2. Does it corrupt the file if you are changing file type using file activities?
  3. Is it possible to have a word template with label already assigned - copy file - update content - use action to save as different doc?

Else, since we are Lithuanian we can take this discussion elsewhere, as I am also working with AIP standard in my team, so I can try sharing some knowledge we have.

Hello, thank you for the help.

  1. AIP label cannot be set for HTM/HTML type files.
  2. I am using word scope or invoke code with Microsoft.Office.Interop.Word functions as I need text to be nicely formatted. I assume you mean different kind of conversion? Would that keep the formatting as expected?
  3. The issue is not with the .docx template but with the newly created HTM file - as it is new file being created, the popup appears to select label for this new file.

Currently the workaround is to kill Word process - it works but is not a quality solution, I suppose.

It would be nice to connect to share RPA best practices, if you are open to it. :slight_smile:

1 Like