How to change the default published package folder of Uipath Assiatant(Attented Robot)?

Are there any solutions to change the default published package folder(“C:\ProgramData\UiPath\Packages”) to another folder for Uipath Assistant(Attended Robot without Orchestrator)?

Thanks in advance.

1 Like


Welcome to uipath forum

While publishing you can mention the Custom url and publish to any folder you want

Refer this doc for more details

Cheers @Chen_Chen

Thanks for your quick reply, Palaniyappan.

But the customed folder(“C:/Test1”) is the folder on the machine that the studio installed.
If I have a robot that is installed on another machine, I also need to copy the published package from “C:/Test1” to the folder(“C:\ProgramData\UiPath\Packages”) on the robot machine.

That’s completely fine
Pubskih to the custom location you want and copy that nuget file and paste it in the default location of the packages where you have the robot
%ProgramData%\UiPath\Packages .

So that you can access the file from there

Cheers @Chen_Chen

Okay, thanks, I am just thinking if there are ways to customize the path(%ProgramData%\UiPath\Packages) of Robot, for example, a network share drive (//
So I can also publish the nuget file to the shared folder(// in order to avoid copying and pasting nuget file every time manually.


We can achieve it editing NuGetServerUrl in UiPath.settings as the following.
It exists in c:\Users[accountname]\AppData\Local\UiPath if installed as user mode.

Note: It’s needed to restart UiPath service if modify UiPath.settings.


Hi Yoichi,

Thanks for your help.

BTW, is this service like screenshot below? I have restarted it, but not work.



Nope, it’s UiPath.Service.UserHost.exe in user mode.
Or it’s good to reboot OS, too.


Thank you so much, Yoichi, It works.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.