How to change column name to column index?


#1

dear ,

I’m not sure why my UIPAth process suddenly not functioning. It said a “column name” not belong to table. I’hv changed from “column name” to “column index”. however, I’m not sure how to change the “write line” expression
row(“Expense Type”).ToString

how can I change “expense type” to column index? thanks~

Write line : Column ‘Expense Type’ does not belong to table .
`Recording (GT-OT) Faulted
Main Faulted
Main Faulted


#2

Hi,

Can you please share the workflow.

Regards,
Rahamtullah


#3

Just a random guess, did you check on header in the excel activity?


#4

dear, I hv checked the header name, but they are all correct. The path was working and it doesn’t work suddenly…thanks


#5

There seems to be issue reading header with recent Excel Read range Activity. Can you try with Workbook read range and see if it works.

Regarding your question: row(ColumnIndex).ToString --> row(1).ToString will give 2nd Column value of that row.


#6

dear @vvaidya,

I have changed all the column name to column index. however, when I click “AddHeaders” in Read Range, it pops up below exception box. however, if I dun click “AddHeaders”, the robot cannot read my row items…may we know how to solve it, thanks~


#7

#8

I am getting the same error today! the code works fine when you unselect the header option. Any idea how to rectify this?

@MichaelC


#9

Hey @MGDEL

If you have the latest Excel package version “UiPath.Excel.Activities.1.2.6256.15131” then the problem with the update so you can use the previous version for now. QA team will look into it.

For more updates on this, read this thread:

and for previous excel package you can install this package:

Best Regards…!!
Aksh