Read Range error

Im getting this kind of error and i dont understand where the problem is. any ideas?

1 Like

Since your Add Headers is checked, can you check if the 1st row of your excel sheet has blank cells? Probably Uipath is throwing null reference exception when trying to convert blank cell to datacolumn.

I may be wrong, also try with work book read range activity and see if you able to get the same error or any other by which you can figure what the issue is.

1 Like

I am also encountering same issues.
4 days before the same thing was working but now UIPath has started throwing errors if headers are blanks.
If we are downloading data from some application and we don’t know the range then how to handle it as it has started throwing errors.
@aksh1yadav @badita @andrzej.kniola any suggestions, why it is behaving like this???



I got mine fixed uninstalling the latest excel activity update.

Can you mention the steps how to install the older Excel activity then?

Ok steps.

  1. Open Package manager
  2. Installed packages (All)
  3. Uninstall Excel.Activities
    (Restart UiPath)

For me it removed the latest update.
Some official steps would be good also, it just worked for me for now… i hope they will fix this soon.

Yes It is confirmed that their is problem with latest Excel Activity packages updates @Gabriel_Tatu @cosmin.sandulescu

But this is only with Excel application scope with workbook activity it is working fine. Others can also confirm this?


workbook works fine for me too. thanks for answers

Yea, workbook is all well…But Excel activity scope is creating problem…so all earlier code is failing :frowning:… Can @UIpath team fix this?

as i`ve asked on another topic, please attach the test file and the workflow, if its possible. if not, tell us what you are doing exactly and i will try to reproduce.

@Gabriel_Tatu Excel Application scope read range activity stopped converting blank cells into “ColumnN” data column if Add header is checked.

Excel Activity Version : 2.0.6333.17728

Csv helper :

excelupdate.xlsx (8.6 KB)
testExcel.xaml (11.2 KB)

can you tell me please with which version of the excel package you’ve tested this and worked?

Well mine is studio version 2016.2.6274 and excel version is 2.0.6333.17728

excel package, not studio.

Didn’t get a chance to check as auto update is checked.But I can say that it was working until May 12th.

i`m asking this because with the previous version, it was the same behavior, so nothing changed.

Will you be able to provide previous version so we can test on our end?

Is there a possibility that because of any other dependency that could got updated recently this issue is happening.

in C:\Program Files\UiPath Studio\Packages you can find different versions of the packages
you can uninstall the existing package, and install the older one from a custom location

For me before update it was working fine but after this update start getting this

what i want to find out is the version of the package that worked for you, not the new one.