Column does not exist

datatable
excel
activities

#1

Hello Everyone,

I am experiencing an issue with the an Excel function. Below is how my data looks like(Sorry i was not allowed to attach the Excel file since I am an new user):

17% 13% 6% 4% Others
TaxableAmt 100 100 100 100 100
Tax 17 13 6 4 7

I used the “read range” function and made sure I selected the “Add Header” selection. Then i used the function datatable.rows(1).item(“17%”), expecting to get the number 17. But it has been trhowing the error “Column ‘17%’ does not belong to table”. It seems that Uipath couldn’t recognize “17%” as a column name while “Others” was recognized.(And i was able to get the number ‘7’, which i expected)

I have double checked everything. But for a process so small and simple, I could not find anything that could go wrong.

Can anyone help? Any input is appreciated!

Thank you so much.


#2

Hi,
Right on.
Try with Column Index instead of name.
It’s working.
including QA team too :slight_smile:
@Andrei_Pop


#3

Hi ddpadil,

Thanks for the reply! Do we know what is causing this? My problem is that the table is not standardized, meaning columns could shift. So I wouldn’t know what the index of 17%, or 13% are.

Could you think of any alternatives to get around with this? My current thought includes some loops. But really not an ideal way as it would be less efficient.

Thank you and please kindly let me know if any solutions.


#4

Hi Everyone,

I am also experiencing the same error with an Excel function that “column doesn’t exist”. I have tried with keeping both column index and value as well, but none of them were working. If anybody know the solution, could you please let me know ???


#5

Try Making The Changes In Your Read Range Activity !
The Range Must be from A1:A2 which is by default! So it must not be reading the columns after A2.
Change it as per Your need!
Try Leaving it blank eg." "