Click ‘DIV’: Cannot send input to UI element because it is outside of screen bounds

Hi guys,

i have a problem with that as i wrote in title. I tried everything but it could not solved my problem.
I have click activity and i did simulate click ok, sendwindowsmsg is ok, dynamic variable is ok.
but these did not work. If i do simulate this error message is gone but click event doesn’t happen or not going. There is a trick somewhere but i couldn’t find where it is.

Thanks

Are you attaching the new window you are trying to click on or is the div actually clickable at the time of trying.

i.e. Dropdown menu or sub menu etc?

Can you pass the selector you are trying to use for that activity

No dropdown or smt
Like that :
i want to click 10

month(str) default value is “10” also tried int and is not working


And my Control Element exist output is true.

What should i do?

Thanks.

What is the original selector without the {{Month}} for aaname?

Your selector is quite generic as all it’s looking for is the aaname={{month}} (10).

can you try add the Class property to the selector.

Or can you send the full website page you are trying to work on.

Without month is original value is 10.

I added class property and not worked either.
11

and site address does not change the when you click the another number.

and also with month variable when i highlighted in click activity it show me the number but when program runs it doesn’t work.

Do you have the wait for page load set to Complete?

Also you can remove idx=’’ / parentid=’’ as they are not adding any benefit to the selector

I have delay activity and also in click activity i did ‘delay after’ and ‘before’ in property.

i deleted idx and parentid and it did not work again. :frowning:

In click property i did WaitForReady : complete but did not work.

Can you share the website url to that page please? I can take a look :slight_smile:

Click HERE

This selector worked for me.
image

month variable is a string

my month also string to.
Can you send ?

Use Hardware Events.

I’ve seen this same problem with an element that’s clearly visible, when using Simulate.

Maybe a UiPath bug.

There is interesting situation happened. The click event it worked in I.E but it doesn’t work in chrome? WHY? i want to see in the chrome and why did happen like that. Chrome extension smt or cache or smt different? i don’t know.

ClickMonth.zip (68.5 KB)

Attached sample of it working.

What is your input mode set to? It’ll be a property of the Click, or a property of Use Application/Browser if you are on modern.

I fixed my problem but the solution is very hilarious. I have a open browser activity, i did not say because i did not necessarily for me the program gave me error in click event so. Anyway, program worked in ie instead of chrome but i changed the browsertype again to chrome and it worked. LOOL. :smile:

Thanks anyway, you work hard :slight_smile:

1 Like

i changed the browsertype ie and it worked and i changed again to chrome and it worked :slight_smile:

Oh, it sounds like you’re using an old version of UiPath.UiAutomation.Activities.

Why aren’t you on modern?

The error caused by idx="" =>
if i erase or use * the problem occures. this idx changing. Can i control this? or making variable can it be fix i do not know.