Help! Upgrade to 4.2 killed UiRobot functionallity, can´t install packages anymore

#### Scenario:
Hi Forum, since we upgraded our environment we cant run processes anymore. Our setup is splitted in a Dev-Environment (on VM) with a Studio and a test-environment running just with an UiRobot without installed studio (another Virtual Maschine). Both are connected to seperated Tenants (two tenants) on the same Orchestrator DB.

After developing we publish the package out of the studio, download it from the dev-Tenant and upload it again into the test tenant. That architecture is mandatory.
When we want to run the process out of the Orchestrator (test-tenant) we see in the UiRobot tray window the project, but it keeps downloading the package forever. The Nuget. projectfolder stays empty too. After 20mins it runs into an "net.pipe://localhost/UiPath/service/executor did not receive a reply… error.

We build another project, which actually can start but freezes at some point in the process and stays in that behaviour. No timeout-error no messeages, nothing. We left it for over an hour in that state without any logs / changes etc Here we dont even get an error.

Steps to reproduce:

Just start any process on the test-vm, orchestrator or uirobot tray doesnt make a difference

Current Behavior:

Doesnt finish the package download -/ installation or just stops the process without any message, robot stays running during that time

Expected Behavior:

packages are downloaded and installed, processes starts to run

Studio/Robot/Orchestrator Version: 4.2

Last stable behavior: before Upgrade
Last stable version: 2.6
OS Version: win 7 professional
Others if Relevant: (workflow, logs, .net version, service pack, etc): we deactivated the anti-virus, checked that all packages are synchronized, read error logs etc. but nothing suspicious.

Anyone faced that topic and could help? It´s kind of urgent :confused:

Hi @Friedrich,

Can you please open windows event viewer > Windows Logs > application and see what (other) errors are logged when the robot is trying to download the packages ? Any errors logged there might be useful to debug the problem.

Also, can you please tell me more about the setup you have:
-do you have the enterprise (msi) installer?
-do you maybe have both msi and community version installed (you can see this in the Programs and features > Uninstall or change a program > look for uipath )
-did you modify anything on the orchestrator feed? like changed it recently.
-do you have any restrictions in your network regarding access to internet - access to nuget feeds that the robot might try to contact

Hi @andreiT,

thanks for your response. The event viewer is full of Errors. I copied some examples, but most of them are caused by Virtual Maschine restart or restarting the robot process I guess:

UnobservedTaskException: System.AggregateException: A Task’s exception(s) were not observed either by Waiting on the Task or accessing its Exception property. As a result, the unobserved exception was rethrown by the finalizer thread. —> System.InvalidOperationException: Connection was disconnected before invocation result was received.

System.AggregateException: One or more errors occurred. —> UiPath.Service.Orchestrator.Clients.OrchestratorHttpException: Robot does not exist.

Fehler beim Erstellen des Wiederherstellungspunkts (Prozess = C:\Windows\system32\rundll32.exe /d srrstr.dll,ExecuteScheduledSPPCreation; Beschreibung = Geplanter Prüfpunkt; Fehler = 0x80070422).

NU1801: Unable to load the service index for source https://api.nuget.org/v3/index.json.

System.Exception: This request operation sent to net.pipe://localhost/UiPath/service/executor did not receive a reply within the configured timeout (00:19:59.9843999). The time allotted to this operation may have been a portion of a longer timeout. This may be because the service is still processing the operation or because the service was unable to send a reply message. Please consider increasing the operation timeout (by casting the channel/proxy to IContextChannel and setting the OperationTimeout property) and ensure that the service is able to connect to the client., HResult -2146233088

-do you have the enterprise (msi) installer? - Yes

-do you maybe have both msi and community version installed (you can see this in the Programs and features > Uninstall or change a program > look for uipath ) -
Just enterprise (the Test VM contains only a robot and all necessary external programs like office etc.)

-did you modify anything on the orchestrator feed? like changed it recently.
just upgrade to 4.2 and implemented the tenant solution (one orchestrator two tenants)

-do you have any restrictions in your network regarding access to internet - access to nuget feeds that the robot might try to contact
within the VM yes, no internet connection beside the Orchestrator and internal programs, but we comment out the download-command line in the NuGet.Config and added inside the UiRobot.exeConfig the line "GeneratePublisherEvidence enabled=“false”

I hope that helps

That is indeed a lot of errors, it’s very hard to tell which one is creating the problem. Can you please clear the logs and try to run a job again.
After that, save all information in an evtx file and send it to me in a pm.
This way we can isolate only the relevant errors.

Have you considered logging a ticket with our support? This seems to be a much deeper problem than “fix X thing”, and we might need an actual call to see the problem firsthand.
If they are not able to resolve the problem, I may be able to join a call if the ticket gets escalated.

Actually, I have a hunch why this may be happening:

I think that because you are in an isolated environment, some nuget feeds that the robot is trying to reach are not responding back, and there are many retries. This leads to very high response time and the executor will finally time-out (hence the " This request operation sent to net.pipe" error ).

What to do:
There are 2 nuget.config files that you need to modify in order to restrict the robot to use just local and Orchestrator feeds:

  1. Robot’s Nuget.config from install folder (C:\Program Files (x86)\UiPath\Studio)
    Just comment or remove the Official and Community feeds :
    Should look something like this:

  1. Local system’s Nuget.config from Windows folder (C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet)

This a bit tricky, if you remove the “nuget.org” feed from here, it will be re-added after service restart.
So what you need to to is keep this “nuget.org” key but change its value to a local folder, like in the example below:

image

Do NOT forget to delete the "protocolVersion=“3” !

Save files, restart the robot service and try again.

-Andrei

2 Likes

Hi @andreiT,

seems like we have a solution for part 1. The package can be installed and the proces starts!

But now we still face the issue that it “freeze”. Bot processes freeze after they read and save something (in this example an excel sheet).
I get a lot of errors in the “alldependencies.json” - project file. Can I solve that without updating by hand everytime?

Can you share the exact error that is logged in event viewer ?

I send you a pm

Ok, I now see you do not have some activities (dependencies). Not sure how those flows you got created with dependencies that are now not found. What version and on what computer did you use to create these flows? Did it have access to internet (and the official feed) ?

Anyway, this can be resolved by:

  1. Repairing the packages to use the local and orchestrator activities and dependencies only:
    Simply open the project on the machine where the robot is installed, right click on red dependencies and press repair:
    image

  2. In case your connection to the official feed is possible, you can use that to retrieve all dependencies that you need (Feed is https://www.myget.org/F/workflow/, you can try to ping it from the robot machine and see if it works)
    So let’s try to put that one back in the robot’s feed and see if you have any more errors or if you go back to the packages cannot be downloaded error.
    To do this, go to Robot’s Nuget.config from install folder (C:\Program Files (x86)\UiPath\Studio) and un-comment the official feed. In the end should look like this:

2 Likes

Hi @andreiT

thanks for the response.
We use the 4.2 on a win7 enterprise vm. The Orchestrator is 4.2 too.

I checked the UiPath Studio Project dependencies but there is nothing to repair. I don´t even see the packages from the logfile I send you.

I also tried the second solution but no change. Robot starts but in the moment he transfer´s data he stop working and freeze “forever”. The connection via VM to the feed isnt possible either.

I´m also not shure because all the files with level= error are some library files from the orchestrator. The packages I installed in the Studio does not have any errors.

Do you have another idea?

If the robot (executor) starts, it’s likely not a problem with the feeds anymore, especially if there are no more errors.
It now seems to be a problem with the flow activities or the driver.

Can you log a ticket with support right now? They might be able to help you more than I can now, and I can also join a call if there is the need for it.

-Andrei

Hi @andreiT,

the ticket got me the same response to change the nuget file in
(Local system’s Nuget.config from Windows folder (C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet))

But yes I will open another ticket specified with that problem

Hi @andreiT

sometimes the simpliest issues cause the biggest problems.
We had some licensing troubles thats why the robot looped forever between licensing check and opening the applicaiton.

But I´m wondering why we dont get a timeout or any error in that case if we run a bigger process. I extracted parts of the process and tested them as standalone and could get the error:

HRESULT: 0x8001010A RPC_E_Servercall_Retrylater"

I did not get that error while running a “big” process with more interaction. Is there any error hierachy implemented in UiPath which decides what kind of errors are thrown or not?

What licensing trouble did you have ? It may help understanding why there was no timeout.
How was your robot licensed, directly from Orchestrator or via a code added into Studio?

I know there is a timeout when it fails to install packages, either because they cannot be downloaded, or because they are downloaded too slow.
But in your case, it seems that the packages were downloaded, but because of your licensing problem, it seemed to be stuck in that retry operation.

Hi @andreiT

the robot´s are correct licensed, its the program we want to automate :slight_smile:

Yes with the packages we have the 20min timeout, but we actually didnt need that packages, the root of the problem was still the licensing. Why it affects the packages that hard idk, but well solved for now.

Thanks

1 Like

Actually, you had two problems.
The problem that I mentioned about the feeds and packages in comment #5 was real. Once you fixed that, the problem about the license manifested itself more than before.
We are currently working on a functionality that will disable the online nuget feeds for the robot and will only use Orchestrator and local one. This will be done through a single parameter setting and you will not have to manually modify all robot feeds (nuget.configs) like I showed you.
We are shipping this in 18.4.4 update that should come out in less than a month (but don’t quote me on that)

-Andrei

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.